error running mcMMO in my craftbukkit server pls help.

Discussion in 'Spigot Plugin Help' started by BJP, May 8, 2015.

Thread Status:
Not open for further replies.
  1. BJP

    BJP

    Everytime i try and run my server with mcMMO i get this error message.... HOW CAN I FIX IT?
    [18:45:41 INFO]: [mcMMO] Enabling mcMMO v1.5.03-SNAPSHOT-b46

    [18:45:42 ERROR]: [mcMMO] There was an error while enabling mcMMO!

    [18:45:42 WARN]: java.lang.UnsupportedClassVersionError: com/gmail/nossr50/metrics/mcstats/Metrics$Plotter : Unsupported major.minor version 51.0

    [18:45:42 WARN]: at java.lang.ClassLoader.defineClass1(Native Method)

    [18:45:42 WARN]: at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)

    [18:45:42 WARN]: at java.lang.ClassLoader.defineClass(ClassLoader.java:621)

    [18:45:42 WARN]: at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

    [18:45:42 WARN]: at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

    [18:45:42 WARN]: at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

    [18:45:42 WARN]: at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

    [18:45:42 WARN]: at java.security.AccessController.doPrivileged(Native Method)

    [18:45:42 WARN]: at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

    [18:45:42 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)

    [18:45:42 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:193)

    [18:45:42 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:97)

    [18:45:42 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)

    [18:45:42 WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

    [18:45:42 WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

    [18:45:42 WARN]: at com.gmail.nossr50.mcMMo_OnEnable(mcMMO.java:184)

    [18:45:42 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:316)

    [18:45:42 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332)

    [18:45:42 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:412)

    [18:45:42 WARN]: at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugin(CraftServer.java:476)

    [18:45:42 WARN]: at org.bukkit.craftbukkit.v1_7_R4.CraftServer.enablePlugins(CraftServer.java:394)

    [18:45:42 WARN]: at net.minecraft.server.v1_7_R4.DedicatedServer.init(DedicatedServer.java:153)

    [18:45:42 WARN]: at net.minecraft.server.v1_7_R4.MinecraftServer.run(MinecraftServer.java:458)

    [18:45:42 WARN]: at net.minecraft.server.v1_7_R4.ThreadServerApplication.run(SourceFile:628)

    [18:45:42 INFO]: [mcMMO] Disabling mcMMO v1.5.03-SNAPSHOT-b46
     
  2. I'm sorry if I'm wrong, but I think the problem is that you've the wrong version of McMMO for your 1.7 server. You should try this version of McMMO, good luck c:
     
  3. BJP

    BJP

    dude that was it ! i had the wrong version of mcMMO holy shit you are a champion haha. but is there any different from the version you told me to download to the latest version of mcMMO?
     
  4. I don't think so.
    Just server types updates.
    @jflory7 lock pls.
     
  5. jflory7

    jflory7 Retired Moderator
    Retired Benefactor

    Thread locked per request

    Next time, please just open a report - it will be resolved faster that way.
     
Thread Status:
Not open for further replies.