Solved Error Starting Server

Discussion in 'Spigot Help' started by mekEE, Mar 27, 2020.

  1. Hi, I need help with my server. I had it running on 1.15.2. I've installed ViaVersion and switched to 1.12.2, but when I try to launch my server now, it doesn't start.
    Sorry If I split a line, because I copied this straight from command prompt and it won't let me edit it. Also I downloaded Spigot from getbukkit.org. Here's the error. Thank you.
    Code (Text):
    Exception in thread "main" java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key org.bukkit.craftbukkit.libs.joptsimple.UnrecognizedOptionException.message
            at java.util.ResourceBundle.getObject(Unknown Source)
            at java.util.ResourceBundle.getString(Unknown Source)
            at org.bukkit.craftbukkit.libs.joptsimple.internal.Messages.message(Messages.java:42)
            at org.bukkit.craftbukkit.libs.joptsimple.OptionException.formattedMessa
    ge(OptionException.java:121)
            at org.bukkit.craftbukkit.libs.joptsimple.OptionException.localizedMessa
    ge(OptionException.java:117)
            at org.bukkit.craftbukkit.libs.joptsimple.OptionException.getMessage(OptionException.java:113)
            at java.lang.Throwable.getLocalizedMessage(Unknown Source)
            at org.bukkit.craftbukkit.Main.main(Main.java:137)
     
    #1 mekEE, Mar 27, 2020
    Last edited: Mar 27, 2020
  2. Dont try to get spigot from anywhere other than Spigot's BuildTools.jar
    https://www.spigotmc.org/wiki/buildtools/
    Read up on it in the link here.
     
  3. I'm trying BuildTools, it seems to take a long time for me.
    Edit: It was successful! I have CraftBukkit and Spigot, I'll copy the files and try now.
    Edit 2: The same error appears. )=
    Edit 3: Solved! =D I removed the -nogui flag from startup which was unnecessary. More info here.
     
    #3 mekEE, Mar 27, 2020
    Last edited: Mar 27, 2020