Solved Error with config.yml

Discussion in 'Spigot Plugin Help' started by JustixDeveloper, May 1, 2017.

Thread Status:
Not open for further replies.
  1. Hey guys, i've got a problem:
    If I start/reload my server, it says:
    Code (Text):
    [12:17:41 WARN]: Caused by: while parsing a block mapping
    in 'string', line 133, column 9:
                ItemID: "262:0"
                ^
    expected <block end>, but found BlockMappingStart
    in 'string', line 136, column 10:
                 Lore: ""
                 ^
    My config.yml:
    https://pastebin.com/3LGjCzqK
     
  2. The Pluginname is Friends 3.0
     
  3. Are you sure 262 is an item? Also for the lore, you can't have a blank lore so add a color code.
     
  4. The problem isn't the item IDs, it's invalid YAML syntax.

    Use this tool to check YAML syntax: http://yaml-online-parser.appspot.com/

    Make sure you have the right amount of spaces. Lore has an extra space for example. The syntax is invalid.
     
    • Informative Informative x 1
Thread Status:
Not open for further replies.