Error with Essentials: Permissions lag notice with (GenericVaultHandler)

Discussion in 'Spigot Plugin Help' started by Itaquito, Nov 4, 2018.

  1. Hey! I get this "error" like 50% of the times I join the server:

    Code (Text):
    [23:42:30 WARN]: [Essentials] Permissions lag notice with (GenericVaultHandler). Response took 31.610665ms. Summary: Getting prefix for _itaquito_
    I think is nothing serious but I just want to know if I can solve it.

    Im using EssentialsX, LuckPerms and VaultChatFormatter as my chat plugin.

    Thanks!
    -Itaquito
     
  2. Try re-doing the essentials config or updating your vault
     
  3. I have the latest version of Vault that is here: https://ci.md-5.net/job/Vault/
    Also, I tried reinstalling essentials completly several times. (resetting all the files)
     
  4. bump

    I'll stop bumping.. at some moment..
     
  5. drives_a_ford

    Moderator

    Have you tried contacting EssentialsX developers?
    Their discord is listed on their sigot page
    https://discord.gg/casfFyh

    If anything, they could at least tell you if they've seen this happen before.
     
  6. I already contact them, they just told me that is not really an error is just saying that is taking 31ms to get a prefix. I guess I will to live with it.
     
  7. I also have this issue and it literally crashes my server
     
  8. I also have this issue 1.14 paper with EssentialsX & luckperms... Thinking it may have to do with slow HDD access times. Read a thread that recommended clearing essentials user cache. I've seen mine up over 2000ms
     
    • Agree Agree x 2
  9. Same issue here.
    Code (Text):
    [Server] WARN [Essentials] Permissions lag notice with (ModernVaultHandler). Response took 166.735748ms. Summary: Getting prefix for <my username>
    Using Paper 1.15.2 Build 260, latest version of LuckPerms, EssentialsX 2.17.2.0 and latest version of Vault.

    EDIT: like the OP stated, according to the EssentialsX developer the warning should just be treated as a simple notice. It means that either the server or the permissions plugin added a delay, and unless you're experiencing heavy lag spikes it can be ignored.
     
    #13 SpaceYoshi, May 7, 2020
    Last edited: May 8, 2020
  10. I made this thread almost 2 years ago! I had been using the same way all this time for making prefixes and formatting the chat, this error only appeared to me once, when I made this thread. So I can conclude that this error is indeed saying that the server is taking too long in order to retrieve the prefix, maybe it happens because the server needs more resources or that something is lagging. If you really care about performance you should maybe look into it. If not, you are probably fine!
     
    • Agree Agree x 1
  11. What I have done to fix this is upgrade to a SSD, add special java flags and well.. basically upgrade everything about my server lol new mobo new cpu new ram etc :) The hardware I used is laughable but thats something I did not realize back then.
     
  12. I just did an ssd upgrade... will see if fixes

    -Edit: looks better now on ssd... Every once and a while still get it
     
    #16 Ice_fly, May 14, 2020
    Last edited: May 18, 2020
  13. I still run into this issue with the latest version of EssentialsX and GroupManager on 1.16.5. It lags my player client until it gets the prefix, so bascially when you join you're like the server crashed for a few seconds.
     
  14. I highly recommend switching to LuckPerms in that case. Hook it up to a MySQL database and it will improve your load times.
     
  15. I appreciate your reply, but ignoring the problem and moving on is not a solution. I have been using GroupManager for almost 6 years without issue. I still want to keep using it until it's discontinued.
    I want a solution in which I still get to use GM.
     
  16. Understandable, I respect that. I've switched from GM to LP, and for my usecase it works perfectly. Since I've switched to a new host the error line has disappeared. Server hardware is similar, so I'm not sure what exactly is causing it to appear. I did change my startup flags.
     
    #20 SpaceYoshi, Feb 20, 2021
    Last edited: Feb 20, 2021