Error with redstone and fluids

Discussion in 'Spigot Help' started by Laguna, Jan 26, 2020.

  1. Hello good morning, I've been with a mistake for many days that I can't find the solution, I hope you can help me.

    The problem I have is that in random moments, the redstone stops working, be it pressure plates, levers, buttons ... and interestingly when placing a bucket of water or some other fluid, it does not cascade, the block stays solid. The fact is that sometimes everything works well and sometimes not. There is also no error in the command console.

    I have several worlds, and the problem appears in all of them.

    No errors appear on the console, I use the latest version of Spigot in 1.14.4. I have checked the Essentials plugins and everything is correct, in prevention everything is deactivated.

    Do you have any idea what it can be? I don't know how to fix it :(. I don't know if it's any use, but this is my list of plugins:

    [​IMG]
     
  2. See if doing /stoplag -c fixes it.
     
  3. It doesn't work friend. I have recorded a small video so you can see what happens.

     
  4. It seems like the server just stops responding. Do you have enough ram/resources allocated to the server?

    Edit: Actually, never mind, that wouldn't explain the water showing up for other players (does it?).
     
  5. Thanks for answering mate. Well, I currently have 4Gb in its premium version here: https://sparkedhost.com/premium-minecraft

    Do you think that could be that ?, that there is overhead on the host ?. I do not have many plugins currently I will have about 12.
     
  6. Are there any kind of messages in the logs, which could be related to overload? Also, how big is the world and how many players are on it? Because if a lot of players are near all kinds of contraptions it could also cause the server to lag behind. 4GB should be enough, but I don't fully know what your server is having to deal with.

    Edit: Actually, is it possible that the server is backing-up at those times. Because that can cause long lag spikes that go away after the back-up is done.
     
  7. My guess would be a plugin. If the tps is at nearly 20 (/tps) and the lever doesnt go down then its clearly a plugin or server.properties spawn-protection configuration
     
  8. The world is not very big, the server has less than a month open, and we are on average 3 or 4 players, it is a server among friends more than anything ^^ Right now there are two players and the ram memory is at 3200 of 4000.

    It does not back up, or at least in the console it does not appear to me. Let's see if I can hire more GB, but I don't have that much money. I am thinking of trying another hosting to see if it is solved.

    Thank you!.
     
  9. Yes, it is usually in 20TPS. I'm going to try leaving only Essencial and Multiverse, to see if the same thing happens, although I have removed almost all the plugins and it was still happening.
     
  10. If you're low on money, don't buy more ram as it shouldn't be needed. It could also be the processor, do you have a way of monitoring the processor usage?
     
  11. [​IMG]

    There are currently 4 players and the memory and CPU is like this. It is usually always more or less in those values ^^
     
  12. In that case, everything seems ok... So... Sorry, but I can't really help you more than this.
     
  13. I thank you very much for all the help. I will continue investigating if I give with the solution I will publish it here ^^
     
  14. Did you try removing ALL plugins?
     
  15. See if doing /stoplag -c fixes it.
     
  16. I have not all been able to. I have left the minimums, MultiverseCore, Essencials, GroupManger and Paradise Land that generates floating islands.

    The problem is, it is not something I can verify by removing or putting plugins, since the error appears at random times. Then it is difficult to find the fault :(.

    If I see that happens often, I will do that, remove them all and play a few days without plugins to see if I can find the fault.

    Yes, I tried too, but I continued with the problem :(. Thanks equally.
     
  17. @Laguna that is caused by LagAssist.