Errors building Spigot? READ THIS FIRST!

Discussion in 'Spigot Help' started by GunfighterJ, Nov 30, 2014.

  1. Well no problem here compiled on my debian dedicated server.

    Code (Text):

    Success! Everything compiled successfully. Copying final .jar files now.
    Copying craftbukkit-1.8.3-R0.1-SNAPSHOT.jar to /home/phoenixpb/Downloads/Sources/buildtool/.
      - Saved as craftbukkit-1.8.3.jar
    Copying spigot-1.8.3-R0.1-SNAPSHOT.jar to /home/phoenixpb/Downloads/Sources/buildtool/.
      - Saved as spigot-1.8.3.jar
     
    Wiki is clear and easy to follow.
     
  2. Exactly!

    I'm struggeling with this since hours! Also see here. It's starting to upset me that there is no other answer than "read the wiki". I DID!!!

    --== SOLUTION ==--

    It's all about the correct URL
    Code (Text):
    https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
     
  3. spigot error :< Who just fix pls :"<
     
  4. Nym

    Nym

    The walk through was really clear and I got through it first time but thus far I am unable to get Essentials or HorseKeep to run correctly on it :/
     
  5. Thanks for the post. I already feel less confused than 2 minutes ago...sorta ;)
     
  6. I CAN'T DO THIS !!!!!!!!!!!!!!!!!!!
     
  7. Sorry, I have followed everything and this still does not work. I have tried buildtools #35 to #40 and still get the same "You must run this jar through bash (msysgit)" and I have uninstalled and reinstalled git and jdk. Right click open with git bash and still the same.
     
  8. Do not use right click, try out using the Git Bash you find in start -> programs
    then use the command cd to navigate to your directory and then run java -jar BuildTools.jar

    And please always use the latest BuildTools version.
     
  9. Right clicking and choosing to use git bash is the same as the program from start menu.. There is something wrong and it seems that everyone wants to blame it on what we are doing instead of actually trying to find a solution. I have tried by just going and cd to the directory, I have also tried typing java -jar and dragging the jar file onto git bash. None of these work and it still tells me the same error. I can run a vanilla server and a forge server just fine, so not sure why I am having so many problems with this.
     
  10. Thank You!
     
  11. Thanks for posting this!
     
  12. This will clear up a lot of questions
     
  13. Hey cool dude, thanks for posting this!
     
  14. I Don't Know ! :p
     
  15. Code (Text):
    Error: Could not find or load main class org.codehaus.plexus.classworlds.launcher.Launcher
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [sh, L:\[DragonsCraft Network]\[Downloads]\Spigot Tools\BuildTool\apache-maven-3.2.5/bin/mvn, install:install-file, -Dfile=work\mapped.ba9a3cce.jar, -Dpackaging=jar, -DgroupId=org.spigotmc, -DartifactId=minecraft-server, -Dversion=1.8.8-SNAPSHOT]
            at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
            at org.spigotmc.builder.Builder.main(Builder.java:307)
     
    how to fix this error i try Buildtool #45 and #46
    put apache-maven-3.2.5 in C:\
    and not work :(
     

Share This Page