Errors building Spigot? READ THIS FIRST!

Discussion in 'Spigot Help' started by GunfighterJ, Nov 30, 2014.

  1. Code (Text):
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD SUCCESS
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 01:10 min
    [INFO] Finished at: 2016-02-14T10:52:58+02:00
    [INFO] Final Memory: 20M/599M
    [INFO] ------------------------------------------------------------------------
    Rebuilding Forked projects....
    fatal: '/L:\[DragonsCraft Network]\[Downloads]\Spigot Tools\BuildTool\Bukkit' does not appear to be a git repository
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
    fatal: ambiguous argument 'origin/spigot': unknown revision or path not in the working tree.
    Use '--' to separate paths from revisions, like this:
    'git <command> [<revision>...] -- [<file>...]'
    Cloning into 'Spigot-API'...
    done.
    Resetting Spigot-API to Bukkit...
    error: Could not remove config section 'remote.upstream'
    HEAD is now at 01d1820 Add non-mutative getCrossProduct method to Vector.
      Applying patches to Spigot-API...
    fatal: Resolve operation not in progress, we are not resuming.
    fatal: could not open '/l/[DragonsCraft Network]/[Downloads]/Spigot Tools/BuildTool/Spigot/Bukkit-Patches/0001-POM-Changes.patch' for reading: No such file or directory
      Something did not apply cleanly to Spigot-API.
      Please review above details and finish the apply then
      save the changes with rebuildPatches.sh
    Error compiling Spigot, are you running this jar via msysgit?
    java.lang.RuntimeException: Error running command, return status !=0: [bash, applyPatches.sh]
            at org.spigotmc.builder.Builder.runProcess(Builder.java:535)
            at org.spigotmc.builder.Builder.main(Builder.java:418)
     
    What is the problem now ? .....

    I SOLVET!

    Reinstall all java to last versions 32 and 64bit
    move "BuildTool" to main user so easily run it as Administrator
    Use last BuildTool jar

    i forget what else try .... but its done, i got the jars :D
    THANKS to ME only!!! :D
     
    #41 BioBG, Feb 14, 2016
    Last edited: Feb 14, 2016
  2. Thanks ! :) OMG Thanks
     
  3. I tried everything (updated 32 and 63bit java, ran Git as admin and not, ran a command from the wiki, downloaded BuildTools again...) but it wasn't working (some error about not finding some file) but I noticed that a missing file was supposed to be on the desktop, so I moved the Spigot folder (server folder) to the desktop, ran Git again and boom, it worked.
    Thanks.
     
  4. Auuu Yes!
    Maybe it's from the limit in the path on windows, that all folders + files that windows try to work with, cannot be more than 256 letters.
    so to do it with no errors, u just need to:

    1. Install Git at default settings.
    2. Update all java JRE and JDK to last stable versions.
    3. Download last version of Maven apache.
    4. Set up Maven to be known by Windows, search in Google for info. [LINK]
    5. use Build tool to build your Spigot :)
    5a. you can use GUI Build tool, it's the same thing.
    6. Run Build tool in lowest folder close to C:\ for example: [ C:\bt ]

    Good Luck! :)
     
  5. làm thế nào để ?
    Code (Text):
    [INFO] Including net.sf.trove4j:trove4j:jar:3.0.3 in the shaded jar.
    [WARNING] spigot-1.9-R0.1-SNAPSHOT.jar, minecraft-server-1.9-SNAPSHOT.jar define 568 overlapping classes:
    [WARNING]   - org.apache.logging.log4j.core.appender.ConsoleAppender$ConsoleManagerFactory
    [WARNING]   - net.minecraft.server.DispenserRegistry$2
    [WARNING]   - net.minecraft.server.DispenserRegistry$12
    [WARNING]   - net.minecraft.server.PathfinderGoalNearestAttackableTargetInsentient
    [WARNING]   - net.minecraft.server.BlockWaterLily
    [WARNING]   - net.minecraft.server.PathfinderGoalHurtByTarget
    [WARNING]   - net.minecraft.server.Entity$4
    [WARNING]   - net.minecraft.server.BlockGrass
    [WARNING]   - net.minecraft.server.PlayerChunkMap$5
    [WARNING]   - net.minecraft.server.Chunk$1
    [WARNING]   - 558 more...
    [WARNING] minecraft-server-1.9-SNAPSHOT.jar, guava-17.0.jar define 1686 overlapping classes:
    [WARNING]   - com.google.common.collect.ImmutableMapValues$1
    [WARNING]   - com.google.common.io.LineProcessor
    [WARNING]   - com.google.common.util.concurrent.AbstractService$5
    [WARNING]   - com.google.common.io.BaseEncoding$StandardBaseEncoding$2
    [WARNING]   - com.google.common.io.ByteProcessor
    [WARNING]   - com.google.common.math.package-info
    [WARNING]   - com.google.common.util.concurrent.SimpleTimeLimiter
    [WARNING]   - com.google.common.io.GwtWorkarounds$5
    [WARNING]   - com.google.common.cache.AbstractCache$StatsCounter
    [WARNING]   - com.google.common.util.concurrent.CycleDetectingLockFactory$Policies
    [WARNING]   - 1676 more...
    [WARNING] gson-2.2.4.jar, minecraft-server-1.9-SNAPSHOT.jar define 153 overlapping classes:
    [WARNING]   - com.google.gson.internal.bind.JsonTreeWriter
    [WARNING]   - com.google.gson.internal.Excluder
    [WARNING]   - com.google.gson.JsonDeserializationContext
    [WARNING]   - com.google.gson.internal.$Gson$Types
    [WARNING]   - com.google.gson.internal.LinkedTreeMap$KeySet
    [WARNING]   - com.google.gson.FieldNamingPolicy$5
    [WARNING]   - com.google.gson.internal.bind.SqlDateTypeAdapter$1
    [WARNING]   - com.google.gson.internal.UnsafeAllocator$2
    [WARNING]   - com.google.gson.FieldAttributes
    [WARNING]   - com.google.gson.internal.$Gson$Types$ParameterizedTypeImpl
    [WARNING]   - 143 more...
    [WARNING] maven-shade-plugin has detected that some class files are
    [WARNING] present in two or more JARs. When this happens, only one
    [WARNING] single version of the class is copied to the uber jar.
    [WARNING] Usually this is not harmful and you can skip these warnings,
    [WARNING] otherwise try to manually exclude artifacts based on
    [WARNING] mvn dependency:tree -Ddetail=true and the above output.
    [WARNING] See http://docs.codehaus.org/display/MAVENUSER/Shade+Plugin
    [INFO] Replacing original artifact with shaded artifact.
    [INFO] Replacing E:\Buildtools\Spigot\Spigot-Server\target\spigot-1.9-R0.1-SNAPSHOT.jar with E:\Buildtools\Spigot\Spigot-Server\target\spigot-1.9-R0.1-SNAPSHOT-shaded.jar
     
     
  6. Forgot to check the wiki (facepalm)
     
  7. i found this problem on the buildtools wiki i am so silly .
    Does anyone know how to whitelist in your Anti Virus software?
     
  8. Another reason for applyPatches.sh to say "Patch failed at ...", in addition to an incompatible setting for core.autocrlf is when am.keepcr is set to true.

    On a pure Windows development PC where core.autocrlf is set to false in general and we want CR is kept as-is in the files, git patch files do not apply properly unless we also set am.keepcr to true. Now I set this in my global config a very long time ago and have since completely forgotten about the problems we had with CR in our patch files.

    If that PC is then used to run BuildTools, then that am.keepcr setting of true will prevent the Spigot patches from applying and you'll get the error "Patch failed...". No amount of checking and setting core.autocrlf will fix the issue.

    Now I guess that *very few* users will have am.keepcr set to true but if they do and have completely forgotten this odd setting then they, like I, may be very confused and frustrated.

    So it's also worth running:
    git config --get-all am.keepcr
    If that comes back with true, try running:
    git config --unset-all am.keepcr
    then re-running BuildTools

    However, note that if you originally needed that setting to make git patches work for Windows development work, then you'll probably want to set it again at least locally in your other Windows development repo.
     
  9. You might want to close the thread!
     
  10. Dont use the beta
     
  11. If you want to whitelist in your anti virus, why not just search it up on youtube? Since every anti-virus is different. :p But there should just be an add button and you can add it in.
     
  12. Thanks dude!<3
     
    • Like Like x 1
  13. Very informative! :)
     
  14. I just use https://getbukkit.org/ to download precomiled builds
     
  15. Thanks for posting this!
     
    • Friendly Friendly x 1
  16. Just read the wiki for it and you will know everything
     

Share This Page