Solved Errors with plugins

Discussion in 'Spigot Plugin Help' started by Chrisdog_93, Jun 6, 2017.

  1. Hi,

    Everytime I install a plugin, I get an error. I'm not the best at reading console but it doesn't even show the plugin in the /plugins list. I'll paste some of the console errors below:

    06.06 05:21:17 [Server] INFO Starting Minecraft server on *HIDDEN IP* 06.06 05:21:17 [Server] INFO Using epoll channel type 06.06 05:21:17 [Server] INFO Set PluginClassLoader as parallel capable 06.06 05:21:17 [Server] ERROR Could not load 'plugins/Hub_v1.4.jar' in folder 'plugins' 06.06 05:21:17 [Server] INFO org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/AndreDeBeer/hub/BungeeHub : Unsupported major.minor version 52.0 06.06 05:21:17 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.8-R0.1-SNAPSHOT.jar:git-Spigot-21fe707-e1ebe52] 06.06 05:21:17 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.8-R0.1-SNAPSHOT.jar:git-Spigot-21fe707-e1ebe52]

    Here's some of it o-o I hardly understand any of it and if anyone can help me it'd be greatly appreciated!
    (The plugin that wasn't working is Hub-v1.4, but every new plugin I've installed since today has run into this error)
     
    #1 Chrisdog_93, Jun 6, 2017
    Last edited: Jun 6, 2017
  2. I'm not the best at reading these either, but it looks like it's trying to load the "Hub_v1.4.jar" file, but it can't find it. Have you already deleted the Hub_v1.4.jar file, as well as the folder that it generated, if any?
     
  3. It also looks like the plugins are different java version / need to be updated to a newer version
     
  4. Update your Java
     
    • Agree Agree x 1
  5. Okay, I'll see if that was the reason why.
     
  6. [​IMG]
    This cant be anything else
     
  7. Yes! that fixed the issue, thanks.
     
    • Winner Winner x 1