Essential signs and world guard?

Discussion in 'Spigot Plugin Help' started by Dognast, Jun 18, 2016.

  1. I have a shop on my server that needs the essentials buy signs (I have essentials-2.x-SNAPSHOT) and I want the shop regioned using world guard (Worldguard-6.1.2) and I regioned the shop but now the signs won't work. I read a topic like this saying you need to get essentialsx, but I can't because group manager is not supported with essentialsx, we'd loose everything we did on essentials and our staff team doesn't know pex.
    Heres my essentials config:
    http://pastebin.com/tsKS0XH6

    and my world guard config if needed
    http://pastebin.com/F83PzHCn

    Thanks!
     
  2. "/rg flag <rg name> use allow" should fix your problem. If not, try this as well:

    "/rg flag <rg name> interact allow"

    If none work ask me and I'll look for some more possibly interferring flags.
     
  3. Use the flags @Bowling219 said above or go into your server properties and set spawn protection to 0
     
  4. And I use EssentialsX and group manager works fine it's just essentials chat, spawn, etc that need an update
     
  5. use PermissionsEx instead of group manager
     
  6. I don't know if you saw but I said "I read a topic like this saying you need to get essentialsx, but I can't because group manager is not supported with essentialsx, we'd loose everything we did on essentials and our staff team doesn't know pex."
     
  7. when I looked up essentialsx it has a bunch of different things for essentials, chat, spawn and everything else. Would I need to get those? And I can't seem to find server properties
     
  8. none of the flags worked :/
     
  9. EssentialsX- https://www.spigotmc.org/resources/essentialsx.9089/
     
  10. Mine works fine with it.
     
  11. Says here
     
  12. No problem. :D