Essentials allow unsafe enchantments

Discussion in 'Spigot Plugin Help' started by FireFlies, Jun 3, 2017.

  1. Hey everyone,

    So I've been scratching my head lately with this weird problem.

    Essentially, you can buy some books that are Efficiency 6, Sharpness 6, Unbreaking 4 etc. Just enchantments that are better than the default ones.

    What I want to do is give players the ability to enchant items using those books. So I've enabled
    Code (Text):
    unsafe-enchantments: true
    and given players the
    Code (Text):
    essentials.enchantments.allowunsafe
    perm.

    It's not working, they can't enchant it. I can only do it, I'm OP but other players with OP can't? So it must be a permission issue? But I can't find the missing permission.

    Any sort of help is appreciated.
    Thank you in advance.

    - FireFlies
     
  2. Enchanting unsafe enchants with Essentials only works with /enchant, not the vanilla anvil.
     
  3. That's also what I thought, so in what way can I make this work? There's obviously something missing since I'm able to do it, but no one else can.
     
  4. Maybe essentials.enchant too? Or a custom anvil plugin?