Solved Essentials bug

Discussion in 'Spigot Plugin Help' started by AndromedaTM, Apr 29, 2017.

    • So recently I found an essential bug that happened with no reason...
    • the bug is simple every time I change the slittest bit on configuration
    • the whole essential plugin crashes...
    • Extras:
    • NO console errors
    • Java 8 is being used ... (latest update)
    • Im using the 1.8 spigot and the 1.8 snapshots of essentials
    • This happened out of sudden with no reason
    • If i change the config back to normal its still bugged
    • IM NOT USING THE ORIGINAL ESSENTIALS JARS. (original-EssentialsGeoIP-2.x-Snapshot) (original-EssentialsXMPP-2.x-Snapshot) I tried using them and not using them..
    • Any help would be gratefull!
    P.s I didint know where to post this,If this is on the wrong category tag a spigot staff member to move it
     
  1. Are you using these ones? https://hub.spigotmc.org/jenkins/job/Spigot-Essentials/ No matter what other essentials jars you want, you're gonna need "Essentials-2.x-SNAPSHOT.jar" Also, after you edit your config file, try copying all your text on http://yaml-online-parser.appspot.com/ and see if any errors come up. If so, fix them! Then try to reload the plugin with "/ess reload"
     
    • Like Like x 1
  2. Yes im using those ones And I used the snapshot.jar
    The only change I did to test it was changing default homes from 3 to 2 and the plugin crashed... give me 5 mins and ill try to see what else I can do to give you more info
     
  3. Im adding "Solved" Since ./ess reload seems to be the correct way...REloading essentials with /plugman reload Essentials causes crash s.o.s thanks for the help!
     
  4. No problem :) glad I could help