Essentials Chat Not Working The Way I Would Like It To

Discussion in 'Spigot Plugin Help' started by GhostAction, May 13, 2015.

  1. So I've found this problem (and I don't know if it's me or the plugin) but whenever I try to change this property:

    format: '{DISPLAYNAME}: {MESSAGE}'

    and type in the server chat, the chat still shows up as:

    <[Owner] Jetlogan> Blablabla

    How can I make it so its like:

    [Owner] Jetlogan: Blablabla

    Like I had it. Thanks.
     
  2. em you want the chat be [Owner] Jetlogan: Blablabla but appears <[Owner] Jetlogan> Blablabla?, it will be that you put it wrong, delete the config and do it again
     
  3. but you ll put '[{DISPLAYNAME}]: {MESSAGE}'
     
  4. Code (Text):
    chat:

      # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks.  Set to 0 to make all chat global.
      # Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
      # Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
      # Users with essentials.chat.question can override this by prefixing text with a question mark (?)
      # You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."
      radius: 0

      # Chat formatting can be done in two ways, you can either define a standard format for all chat.
      # Or you can give a group specific chat format, to give some extra variation.
      # If set to the default chat format which "should" be compatible with ichat.
      # For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting
      #Remember this is the global option
      format: '&7{LEVEL} &e{DISPLAYNAME} &f{MESSAGE}'
      #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'

      group-formats:
      #NameRange: '{DISPLAYNAME} {MESSAGE}'
       
      # If you are using group formats make sure to remove the '#' to allow the setting to be read.
     
     
  5. - What plugin you use for permits?

    group-formats:
    #RangeNameInPermits: '&4&lOWNER {DISPLAYNAME} {MESSAGE}'

    To make visible the ranges each user please use: format: '[{GROUP}] {DISPLAYNAME}: {MESSAGE}'

    Be sure to remove the "#". With them no changes in the configuration. I hope I have been as clear!
     
    #5 Amariyo, May 13, 2015
    Last edited: May 13, 2015
  6. Download Essentials, EssentialsSpawn, EssentialsChat, ("Essentials Groupmanager")
     
  7. I actually found the problem. It was something to do with Factions.