Essentials Doesn't Work

Discussion in 'Spigot Help' started by PotatoTears, Nov 2, 2013.

  1. Mikgreg


    That means you already have a server running with the same IP & Port, change your port in the
  2. Mikgreg

    But i don't? That's my only server
  3. That happens when your local address is already used for the same port, which in this case is 25565. That means that you have another server running while trying to open up another one. Java can get buggy, so I recommend force closing it using the Task Manager. (Task Manager Home -> Processes -> javaw.exe -> End process). Afterwards try starting your server up again.

    Here is the server I was testing this on:

    It really looks like your plugin versions are outdated compared the Spigot build. Please update them or grab them from the link I provided.
    • Informative Informative x 1
  4. Maulss
    Thanks, that helped. I can run my server now.

    And i don't think my plugin versions are outdated. I have one plugin that is for 1.7 but i don't use it anyways, so i'll remove it.

    I'll get back to you on the Essentials Chat thing.
  5. Essentials Chat still displays <NAME> TEXT
  6. Mikgreg


    For the 3rd time, what plugins do you have?
  7. Like I said, please try using the Essentials versions I provided in the link, or update them from Bukkit Dev. I can't help you with this stuff if I don't know if your versions are correct.
  8. Maulss

    I downloaded these .jar-s you sent me.
    Still having the same problem.


  9. I tested your chat format with an updated version of Essentials and Spigot. They all work fine.
  10. Maulss

    But the chat format doesn't work for me and i don't know why! :(
  11. Dmck2b

    Services Staff

    Might PermsEx be causing a conflict? Doesn't that have a prefix/suffix system?
  12. Dmck2b
    I tried removing all of my plugins, but Essentials Chat format still doesn't work.
    So, the problem isn't in my plugins...
  13. Remove everything else other than your plugins folder then.
    Afterwards download a FRESH Spigot build and start up the server. Let it generate the config, the worlds and all other files and folders.
  14. Maulss
    Just tried that, still the same thing. :(
  15. Sorry for the late response.

    As I was saying, I used your configuration file with proper Spigot and Essentials versions. It worked for me. This means that there is no problem in your config file, but instead with something that conflicts your Essentials.

    If you want me to help investigate the issue, send over your server folder with only Essentials and Essentials.jar installed.
  16. Maulss I'll send it tomorrow!
  17. I knew it, your jars were outdated.
    Please download the following files which I confirmed are compatible with together:

    Spigot 1.6.4 (Jenkins)
    Essentials 1.6.4 (DBO)

    After I used your Spigot build I'm pretty sure your Essentials jars were newer than the Spigot jar, I'm not sure though.
    I have tested with those jars and it worked fine.

    EDIT: Everything worked, but it was still producing errors in the console. I went ahead and started experimenting with the versions. It turns out even the Recommended CB failed to play nice with Essentials, who were built for their versions.

    After I scratched my head a bit, I had a feeling something was wrong with your server configuration. I deleted all the files and folders (Except for 'plugins') and I let Spigot regenerate all the files and folders again. I've tested the chat again and it worked as intended with no errors. Now to figure out what was causing the problem...

    ANOTHER EDIT: I realized you don't really have a main world folder, and instead it's kept in your root directory, whereas they're meant to be in a special folder for itself called 'world'. I then looked at your and you left out the:
    By adding the world name to the setting, somehow it prevents a chat bug o_O
    #39 Maulss, Nov 4, 2013
    Last edited: Nov 4, 2013
    • Winner Winner x 1
  18. Maulss

    Thanks man!!!

    Problem solved. Doing this also fixed some other problems i had. Thank you!!