essentials kit delay/cooldown

Discussion in 'Spigot Plugin Help' started by badboy983, Jul 4, 2015.

  1. So Hey, I'm having trouble with my kit delays. Players can literally just spam the same kit over and over again, I've looked at the essentials website and they said set it to seconds.
    I've followed many different walkthroughs and no joy:

    kits:
    Cadet:
    Cooldown: 172800
    items:
    - 310 1 protection:2 name:&eCadetHelm
    - 311 1 protection:2 name:&eCadetChest
    - 312 1 protection:2 name:&eCadetLegs
    - 313 1 protection:2 name:&eCadetBoots
    - 278 1 Efficiency:6 Unbreaking:8 Fortune:4 name:&eCadetPickaxe
    - 276 1 sharpness:2 name:&eCadetSword

    If you want to see my permission folder just let me know.
    Thanks in advance
     
  2. Hey I'd love to help, please put your config in a pastebin for me, thanks :)
     
  3. change cooldown to delay
     
  4. Hi guys, It was delay first but I changed it to cooldown incase I was doing it wrong.
    I recently added a plugin called 'commandcooldown' but my only problem now is they have access to /feed and he command works, ''you must wait blah blah'' but if they do /eat they can spam the command. I've look at how to disable it and no joy. I added it to the section on essentials and it still doesn't work
    my second question is, my kit delay command works for /kit but if I want the player how to have multiple kits. the normal command is 'commandcooldown.kit{number}
    but my question is will it work if I do 'commandcooldown.kitImperial{number}?

    here is my essentials files: http://pastebin.com/2kVrSStA
     
    • Funny Funny x 1
  5. If you're using command cooldown just for kits it is unnecessary, I believe that it override the essentials because /eat is a disabled command in essentials and you said you could use that. Is it perhaps that you are trying all this while being an OP? Your config is fine no errors inside of it. But between line 314 and 315 my config has a space, I don't think that's anything though because you said the kits work just fine.
     
    • Like Like x 1
    • Useful Useful x 1
  6. I'm not opped on the server.. I reverted everything back to how it should be and the delay is still not working.
    This is why I was using command cooldown.
     
    • Funny Funny x 1
  7. Make sure none of the user's have essentials.kit.exemptdelay in there permissions. I would try to delete CC and just try essentials again. CC seems to interfere.
     
    • Funny Funny x 1
  8. Just remove permission essentials.kit.*
     
  9. if you are op you can baypass the coldown or remobe Essentials.kit.*
     
    • Useful Useful x 1