Essentials Parsing Error Problem

Discussion in 'Spigot Plugin Help' started by Creeper_Math, May 22, 2017.

  1. Hi, I've tried this before on craftbukkit, but also on spigot, the Essentials plugin isn't working

    So here's my paste of plugins
    [14:59:05 INFO]: Plugins (15): Orebfuscator4, NoCheatPlus, WorldEdit, CoreProtect, EasyWarp, OpenInv, PermissionsEx, MCBans, MotdManager-Reloaded, Essentials, EssentialsProtect, EssentialsSpawn, VanishNoPacket, EssentialsChat, EssentialsAntiBuild​

    And here's what happens when I try /help, which is similar to when I try auto-completion

    [14:59:02 WARN]: Unexpected exception while parsing console command "help"
    org.bukkit.command.CommandException: Unhandled exception executing command 'help' in plugin Essentials v2.13.1
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.dispatchCommand(CraftServer.java:650) ~[spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.dispatchServerCommand(CraftServer.java:636) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.DedicatedServer.aM(DedicatedServer.java:437) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.DedicatedServer.D(DedicatedServer.java:400) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_79]
    Caused by: java.lang.NullPointerException
    at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:389) ~[?:?]
    at com.earth2me.essentials.Essentials.onCommand(Essentials.java:380) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot-1.11.2.jar:git-Spigot-3fb9445-6e3cec8]
    ... 8 more
    I don't know if this is due to a conflicting plugin, or what. It's the 1.11.2 version.
    I'm doing everything through SSH on a linux server, and I don't know what version of Java it has.