Essentials refuses to work

Discussion in 'Spigot Plugin Help' started by insomniac, May 31, 2017.

  1. I have tried installing Essentials on a 1.11.2 Spigot server, trying both EssentialsX and the Maven variant. Neither of them work, they don't load at all unless it is Essentials Protect which starts in emergency mode. I'll give as much info as possible. Other plugins work fine

    [SERVER INFO]
    8GB Dedicated Server
    CentOS 6

    [JAVA VERSION]
    java version "1.6.0_41"
    OpenJDK Runtime Environment (IcedTea6 1.13.13) (rhel-1.13.13.1.el6_8-x86_64)
    OpenJDK 64-Bit Server VM (build 23.41-b41, mixed mode)
    (as according to the server command java -version)

    [STARTUP SH FILE]
    http://pasteo.hosthorde.net:8080/view/8585d09f
    (I know it is minecraft_server.jar, I just renamed it from spigot)

    - Here is the code I used to generate my 1.11.2 spigot jarfile
    http://pasteo.hosthorde.net:8080/view/07d50334

    Thank you. I hope to receive help soon!
     
    #1 insomniac, May 31, 2017
    Last edited: May 31, 2017
  2. Hello there! Are you sure you're using the right version of essentials? You can click here to see the Jenkins for Essentials, where you can download some of the latest versions of the plugin. Hope you can get this figured out!
     
  3. I tried that link, as well as the latest EssentialsX. Same error for both :(
     
  4. Gaxan

    Supporter

    Can you post a start up log with the essentials plugins?
     
  5. Only thing I can suggest is trying an older version, maybe? Super sorry about this problem you're having...
     
  6. Gaxan

    Supporter

    the first line is odd. Cannot allocate memory, is this a dedicated box or VPS?
    I saw you say dedicated, but 8GB is small for a dedicated.
    You are using too much memory in your start up script.
    This is your first problem.

    Next issue, java is outdated. You need to update java.
     
  7. Yeah, I figured out the first part. The inital start up script amount is fine but the Max perm size is too much so I'm going to remove that and update java. Get back to you soon!!
     
  8. IT WORKS!! haha thank you so much I love the internet
     
  9. Gaxan

    Supporter

    Glad I could help.
     
  10. When you have any question, write me a private message :)
     
    • Like Like x 1