Essentials Warps

Discussion in 'Spigot Plugin Help' started by Timotej4487, Jun 1, 2016.

  1. Essentials warps doesn't work for me. The players can't use /warps and /warp shop and so on. Also I want to ask if its possible to disable /spawn in a zone with World Guard or something?

    Here is my essentials config.yml: http://pastebin.com/AuD1gt8s

    Here is my permissions.yml (im using Permissions Ex): http://pastebin.com/Zh0FKqkF
     
  2. Okay, so I am not going to spoon feed you but. To give a player a essential permission it always starts with essentials.(variable) and so on so I want you to go look up "Essentials permission nodes" and you should find your answer for the warp permissions. Now with the world guard you need to do this

    /region flag <region> cmds-block (command name)

    You don't need a slash so an example would be. say your blocking the command spawn and so you do
    /region flag <region> cmds-block /spawn
    your blocking the command //spawn

    If I helped please leave me a rating and mark as solved
     
    • Like Like x 1
  3. Thx for the world guard. But I don't know how to find the essentials permission nodes and what to do then.
     
  4. Did you enable the command in the Essentials config?
     
  5. You're going to go here http://wiki.ess3.net/wiki/Command_Reference/Perm once your are there you should see a search box in it and look up "warp" and you need to make sure it is enabled in your config.yml file.
    Is any OP able to use warp?
     
  6. what command?
     
  7. doesn't work
    /warp doens't work either
     
  8. essentials.warp is the main responder permission for /warp
    Can we see a hastebin of your essentials config file please?
     
  9. Yes
     
  10. http://pastebin.com/piNgMEK5
     
  11. Give them the following nodes:

    essentials.warp
    essentials.warp.list
    essentials.warps.[WarpName]
    That is all the perms for essentials warps. I believe you need to enable per-warp-pernission

    How to do so?
    Set per-warp-permission to true in config.yml and try again as non OP. Let me know if this works
     
    • Useful Useful x 1
  12. It worked! :D I just forgot to give the permission essentials.warp :) Thanks :) I'll rate you :D
     
  13. Make sure that you mark the thread as "Solved" so future people can look at it if they have problems ;)
     
  14. How? :c
    Im new at spigot forums :3
     
  15. Just PM a moderator
     
  16. If you file the red?
    If you / pl it is there red?