Essentials Wont Let Me PVP.

Discussion in 'Spigot Plugin Help' started by radenblazed, Feb 23, 2015.

Thread Status:
Not open for further replies.
  1. Its as the tittle says. i have done just about everything to try and fix it.

    so far i:
    1. I narrowed it down to the essentials "Essentials-2.x-SNAPSHOT" file (i ran my server with just that plugin via trial and error)
    2. I i checked all my config files server.properties (pvp=true) , the essentials config (pvp: false), ect ect.

    it does not give me any notification. it just doesnt do nothing when i attack another player. As soon as i remove Essentials-2.x-SNAPSHOT it lets me pvp again.

    Code (Text):

    ############################################################
    # +------------------------------------------------------+ #
    # |                 EssentialsProtect                    | #
    # +------------------------------------------------------+ #
    ############################################################

    # This section requires the EssentialsProtect.jar to work.

    protect:

      # General physics/behavior modifications.
      prevent:
        lava-flow: false
        water-flow: false
        water-bucket-flow: false
        fire-spread: true
        lava-fire-spread: true
        flint-fire: false
        lightning-fire-spread: true
        portal-creation: false
        tnt-explosion: false
        tnt-playerdamage: false
        tnt-minecart-explosion: false
        tnt-minecart-playerdamage: false
        fireball-explosion: false
        fireball-fire: false
        fireball-playerdamage: false
        witherskull-explosion: false
        witherskull-playerdamage: false
        wither-spawnexplosion: false
        wither-blockreplace: false
        creeper-explosion: false
        creeper-playerdamage: false
        creeper-blockdamage: false
        enderdragon-blockdamage: true
        enderman-pickup: false
        villager-death: false
        # Monsters won't follow players.
        # permission essentials.protect.entitytarget.bypass disables this.
        entitytarget: false
        # Prevent the spawning of creatures.
        spawn:
          creeper: false
          skeleton: false
          spider: false
          giant: false
          zombie: false
          slime: false
          ghast: false
          pig_zombie: false
          enderman: false
          cave_spider: false
          silverfish: false
          blaze: false
          magma_cube: false
          ender_dragon: false
          pig: false
          sheep: false
          cow: false
          chicken: false
          squid: false
          wolf: false
          mushroom_cow: false
          snowman: false
          ocelot: false
          iron_golem: false
          villager: false
          wither: false
          bat: false
          witch: false
          horse: false

      # Maximum height the creeper should explode. -1 allows them to explode everywhere.
      # Set prevent.creeper-explosion to true, if you want to disable creeper explosions.
      creeper:
        max-height: -1

      # Disable various default physics and behaviors.
      disable:
        # Should fall damage be disabled?
        fall: false

        # Users with the essentials.protect.pvp permission will still be able to attack each other if this is set to true.
        # They will be unable to attack users without that same permission node.
        pvp: false

        # Should drowning damage be disabled?
        # (Split into two behaviors; generally, you want both set to the same value.)
        drown: false
        suffocate: false

        # Should damage via lava be disabled?  Items that fall into lava will still burn to a crisp. ;)
        lavadmg: false

        # Should arrow damage be disabled?
        projectiles: false

        # This will disable damage from touching cacti.
        contactdmg: false

        # Burn, baby, burn!  Should fire damage be disabled?
        firedmg: false

        # Should the damage after hit by a lightning be disabled?
        lightning: false

        # Should Wither damage be disabled?
        wither: false

        # Disable weather options?
        weather:
          storm: false
          thunder: false
          lightning: false
     <-- No seriously, you're done with configuration.

    Code (Text):
    #Minecraft server properties
    #Sun Feb 22 17:39:48 CST 2015
    spawn-protection=16
    generator-settings=
    force-gamemode=false
    allow-nether=true
    gamemode=0
    enable-query=false
    player-idle-timeout=0
    difficulty=1
    spawn-monsters=true
    op-permission-level=4
    resource-pack-hash=
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=false
    max-players=25
    network-compression-threshold=256
    max-world-size=29999984
    server-port= :P
    debug=false
    server-ip= :P
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    online-mode=true
    max-build-height=256
    level-seed=
    motd=\u00A7b             \u00A7m\u00A7l---\u00A7r\u00A78\u00A7m\u00A7l[-\u00A74 SWORD \u00A7eAGE \u00A7r\u00A78\u00A7m\u00A7l-]\u00A7b\u00A7m\u00A7l--- \u00A76
    enable-rcon=false
     

    please help me :'(
     
  2. Are you by any chance in "/god" mode? Also essentials is modular so without the EssentialsProtect.jar that section of the config doesn't do anything.
     
  3. well i removed all my plugins and just left essentials in the plugin folder and thats what was causing the problem... btw i made shure that it wasent god mode just now :(
     
  4. i did use the /reload command a cupple of times not knowing that it can cause problems.... but i did replace the essentials plugins with new ones and just kept the config files... unless the /reaload command somehow messed up the actual spigot server? ima try to do a complete server reinstall, ill post the results in a bit
     
  5. if you have worldguard, have you tried /rg flag __global__ pvp allow
     
  6. Polygoon

    Supporter

    If you have multiverse make sure to enable pvp in the config.
     
  7. Which plugins do u run on your Server ?
     
  8. I figured it out. it was the users folder inside the essentials plugin folder... when i deleted it it allowed pvp again, idk exactly why it did this but this is my first server and i was using the /reload command a good bit at the beginning, i didnt know that the command can corrupt plugins... im reloading all my plugins and server files just in case it messed something else up that im not aware of.
     
    • Funny Funny x 1
  9. try not to use the /reload command so often, id suggest using Plugman to reload plugins in game. Its safe and efficient. Its great for finding what plugins are causing your problems as well x]
     
    • Agree Agree x 1
  10. So far, you have PvP disable in your config.yml file. Enable it. I'm surprised that no one actually noticed that.
     
  11. Code (Text):

    pvp=true
     
    change it too
    Code (Text):

    pvp=false
     
    then restart. change it too
    Code (Text):

    pvp=true
     
    restart one more time.

    Then it should work
     
  12. Only 8 months late :p
     
  13. Code (Text):

      # Disable various default physics and behaviors.
      disable:
        # Should fall damage be disabled?
        fall: false

        # Users with the essentials.protect.pvp permission will still be able to attack each other if this is set to true.
        # They will be unable to attack users without that same permission node.
        pvp: false
     
    Copy and paste this one

    Code (Text):


    ############################################################
    # +------------------------------------------------------+ #
    # |                 EssentialsProtect                    | #
    # +------------------------------------------------------+ #
    ############################################################

    # This section requires the EssentialsProtect.jar to work.

    protect:

      # General physics/behavior modifications.
      prevent:
        lava-flow: false
        water-flow: false
        water-bucket-flow: false
        fire-spread: true
        lava-fire-spread: true
        flint-fire: false
        lightning-fire-spread: true
        portal-creation: false
        tnt-explosion: false
        tnt-playerdamage: false
        tnt-minecart-explosion: false
        tnt-minecart-playerdamage: false
        fireball-explosion: false
        fireball-fire: false
        fireball-playerdamage: false
        witherskull-explosion: false
        witherskull-playerdamage: false
        wither-spawnexplosion: false
        wither-blockreplace: false
        creeper-explosion: false
        creeper-playerdamage: false
        creeper-blockdamage: false
        enderdragon-blockdamage: true
        enderman-pickup: false
        villager-death: false
        # Monsters won't follow players.
        # permission essentials.protect.entitytarget.bypass disables this.
        entitytarget: false
        # Prevent the spawning of creatures.
        spawn:
          creeper: false
          skeleton: false
          spider: false
          giant: false
          zombie: false
          slime: false
          ghast: false
          pig_zombie: false
          enderman: false
          cave_spider: false
          silverfish: false
          blaze: false
          magma_cube: false
          ender_dragon: false
          pig: false
          sheep: false
          cow: false
          chicken: false
          squid: false
          wolf: false
          mushroom_cow: false
          snowman: false
          ocelot: false
          iron_golem: false
          villager: false
          wither: false
          bat: false
          witch: false
          horse: false

      # Maximum height the creeper should explode. -1 allows them to explode everywhere.
      # Set prevent.creeper-explosion to true, if you want to disable creeper explosions.
      creeper:
        max-height: -1

      # Disable various default physics and behaviors.
      disable:
        # Should fall damage be disabled?
        fall: false

        # Users with the essentials.protect.pvp permission will still be able to attack each other if this is set to true.
        # They will be unable to attack users without that same permission node.
        pvp: true

        # Should drowning damage be disabled?
        # (Split into two behaviors; generally, you want both set to the same value.)
        drown: false
        suffocate: false

        # Should damage via lava be disabled?  Items that fall into lava will still burn to a crisp. ;)
        lavadmg: false

        # Should arrow damage be disabled?
        projectiles: false

        # This will disable damage from touching cacti.
        contactdmg: false

        # Burn, baby, burn!  Should fire damage be disabled?
        firedmg: false

        # Should the damage after hit by a lightning be disabled?
        lightning: false

        # Should Wither damage be disabled?
        wither: false

        # Disable weather options?
        weather:
          storm: false
          thunder: false
          lightning: false
     <-- No seriously, you're done with configuration.
     
    Here you are!
     
Thread Status:
Not open for further replies.