Solved Essentials /xp not correct.

Discussion in 'Spigot Plugin Help' started by mine625, May 22, 2016.

  1. I recently downgraded from 1.8.8 spigot to the 1.7/1.8 spigot protocol hack. When I did this I also switched to EssentialsX. From then on, the /xp command displays the incorrect xp amount. Any way to fix this?
     
  2. Thats the thing, there are no errors that show in the console...

    Also spawners aren't working with EssentialsX, if I do /i 52:61 (Blaze Spawer) and place it, it turns into a pig.
     
  3. Seems to be only your side, it's working fine for me.
     
  4. Maybe Your Computer or server is messed up @mine625
     
  5. Have you tried doing /xp set 10L ? L - Levels?
     
  6. You might have some other plugin or something not liking essentials.
     
  7. What can possibly be the enemy of Essentials.. o-o
     
  8. Hey, now they're plugins, they tend to not like one another. xD
     
  9. @NotWhiteyLol this sets my xp to 160 points, but only gets me to 9.5 levels.

    EDIT: I'm on 1.7.10 if that matters.
     
  10. I guess so. #BetterCodings.
     
  11. There you have it. It's not the most accurate in the world but it got you to 9.5 :D Btw XPs are not set by levels :p
    They added the L in there so it would be easier for us to give XP by adding the Level variable.
     
  12. Have you got the correct version of essentials?
     
  13. But is there a way to make it so if I do /xp set 10L it puts me to 10 levels.

    @Bloodshot_pico I'm using EssentialsX build 330
     
  14. Can you send me the link to where you got it from please? :)
     
  15. Ah I see, well I'm not sure but I'm pretty certain that you're using a updated version of Essentials that doesn't support 1.7, it's more of a 1.8.x kind of thing. Yet again I'm not sure.
     
  16. Reinstalled my custom enchants plugin and essentials and it works.