EssentialsX Java ZIP error

Discussion in 'Spigot Plugin Help' started by Loulou, Apr 17, 2018.

  1. Hello,

    Since updating to the latest spigot version (1.12.2 of April 15th 2018) and the latest EssentialsX version 2.15.0.1, I am getting errors for *all* EssentialsX plugins (the same type of error for each) when starting the server. It says something about a problem opening a ZIP file, but I only have JAR files in there... However, this doesn't seem to stop the plugins from working (they are all green when typing "plugins"). The server is running on Ubuntu 16.04 Server. I've tried deleting and downloading the plugins again, with no success. Also tried rebuilding the server from the latest snapshot. Any ideas? Thanks.

    Code (Text):
    [19:39:17 ERROR]: Could not load 'plugins/._EssentialsX-2.15.0.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
            at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:160) ~[spigot-1.12.2.jar:git-Spigot-eadd615-bea
    5a84]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot-1.12.2.jar:git-Spigot-eadd615-bea5a84]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:305) [spigot-1.12.2.jar:git-Spigot-eadd615-bea5a84]
            at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:205) [spigot-1.12.2.jar:git-Spigot-eadd615-bea5a84]
            at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [spigot-1.12.2.jar:git-Spigot-eadd615-bea5a84]
            at java.lang.Thread.run(Thread.java:748) [?:1.8.0_162]
    Caused by: java.util.zip.ZipException: error in opening zip file
            at java.util.zip.ZipFile.open(Native Method) ~[?:1.8.0_162]
            at java.util.zip.ZipFile.<init>(ZipFile.java:225) ~[?:1.8.0_162]
            at java.util.zip.ZipFile.<init>(ZipFile.java:155) ~[?:1.8.0_162]
            at java.util.jar.JarFile.<init>(JarFile.java:166) ~[?:1.8.0_162]
            at java.util.jar.JarFile.<init>(JarFile.java:130) ~[?:1.8.0_162]
            at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:148) ~[spigot-1.12.2.jar:git-Spigot-eadd615-bea
    5a84]
            ... 5 more
     
     
  2. Are you running a custom build of essentials? Because it says that the plugin.yml is invalid
     
  3. Not at all, I wouldn't know how to do that... I just downloaded the jar files (from here) and placed them in the plugins folder, like any plugin.
     
    #3 Loulou, Apr 17, 2018
    Last edited: Apr 17, 2018
  4. Jar files are actually zip files, just with a different extension. I would recommend re-downloading the plugin. If the error persists, try a different version (e.g. one version older) until it works.
     
  5. I've sampled several builds ranging from the last one (#615) and going as far back as #516 from August 2017. I still get the exact same error with all of them (error in zip file and/or plugin.yml). I don't have anything like in any of the other plugins I use, it only happens with EssentialsX.

    BTW, there is no plugin.yml file anywhere on the server.
    Code (Text):
    find . -iname "plugin.yml"
    The above doesn't return anything. Could that be the problem? Where is the plugin.yml supposed to come from?
     
  6. The plugin.yml file is located inside the plugin's jar file.
     
  7. Thanks for the ideas. The link provided by @drtshock is the same as the one I mentioned in my post. I'm using latest Firefox but tried again using Chrome, same thing (the file sizes are identical). Could it a problem with Ubuntu's Java implementation? I've installed all the updates to the OS (with apt-get update & upgrade) just in case, but it didn't help either.
     
  8. MiniDigger

    Supporter

    try opening the jar file with an archive viewer, you should see a plugin.yml in the root of the file.
    it generally looks like the jar got corrupted, maybe someone can provide an essentials jar with a hash so that you can validate the integrity and that you fully downloaded the file.
     
  9. OK, found it! Look carefully at the error message in my original post, the filename starts with "._" which is, apparently, an invisible and useless file created when I copy the download jar file from my Mac (where I work) to my networked Ubuntu machine (where the server is running) via SMB. I just needed to remove the invisible file after copying the real jar file and the error disappeared.

    I don't know which part of the chain is responsible for this (Mac, Ubuntu, SMB) but apparently something has changed in recent months, because I've never encountered this phenomenon before.

    The invisible file also explains why I was getting error on launch while *still* having a perfectly functional EssentialX.

    Anyway, thanks a lot to everyone for your encouragement and help, which put me on the right track.

    Cheers.
     
    • Useful Useful x 1

Share This Page