EssentialsX Warps command not working

Discussion in 'Spigot Plugin Help' started by Shampou22, Apr 19, 2017.

Thread Status:
Not open for further replies.
  1. So, to explain what I made, I made a warp that is called hub so players can get to the hub by typing /warp hub and I replaced the command with /hub and I did the same with /warp creativespawn. My problem is now, everytime I type /warp hub or /hub or /warp creativespawn, it says I have no permission, I added myself to the member (default group) and also added the permissions that are needed..

    commands.yml
    permissions.yml


    My issue is, I created /warp hub and /warp creativespawn, and replaced the command /warp hub > /hub in the commands.yml. But everytime I try /warp hub or /hub or /warp creativespawn, it says I have no permission, I added the permissions! I will look forward for help :)

    PS: Sorry for my bad english :oops:
     
  2. Try adding the permission essentials.warp because Essentials probably checks that before it checks any other permission related to it.
     
    • Like Like x 1
  3. It didn't work! :( But thank you for your response! :D Oh and btw! The message changed after I added the permission essentials.warp ! It first said "You do not have access to that Command." and now after I added essentials.warp it's saying "You don't have permission to that warp." ! I have set per-warp-permission: true in the config file of Essentials. Would it help if I would set it to false?

    EDIT: Fixed some message errors :)
     
  4. I personally don't use per-warp-permission because I don't set warps that I don't want my players to use, unless I don't want them to use any of them and just don't give them the essentials.warp permission. So if you have some warps you want your players to use and some you don't, then you should keep it on. Otherwise it's easier to disable it. Also in your permissions.yml it should be essentials.warps.warpname
     
    • Like Like x 1
  5. Thank you for your help! I fixed this by just putting the per-warp-permission to false! My players can use all warps, its fixed now! :D Thank you a lot! How do I lock this thread?
     
  6. Click the Thread tools text next to the Unwatch Thread text just above the right-hand corner of your first post. Then uncheck the box that says Open.
     

    Attached Files:

Thread Status:
Not open for further replies.