Every time I go to my island (ASkyBlock) I die.

Discussion in 'Spigot Plugin Help' started by 09TheMobLordXx, Feb 2, 2020.

  1. So I have a big problem on my Skyblock server when I type /is and go to my island, I automatically die.
    So how I die is just a one-second death. I type /is, I teleport, I die instantly.

    Plugins I have Installed: Plugins (70): CustomOreGen, PlaceholderAPI, DeluxeCommands, CoinFlip, PlatinumChat, Arconix, SkinsRestorer, DeluxeTags, BCommons, CustomDrops, NoDeathMessage, ViaVersion, NBTAPI, HungerKeeperPlus, QuickBoard, DragonMOTD, ArmorStandEditor, WorldBorder, MessageAnnouncer, SmartBans, Votifier, ProtocolLib, MVdWPlaceholderAPI, FastAsyncWorldEdit, Vouchers, DeluxeMenus, DivineDrop, PermissionsEx, NoWeather, Vault, TokenManager, CrazyCrates, EpicRename, MoneyPouch, HolographicDisplays, Vote, ASkyBlock, TimedRewards, ChatItem, PlayerVaults, WorldEdit, Essentials, SkyBlockChat, BountyHunters, BuycraftX, SkyLevels2, Multiverse-Core, VoidSpawn, KitAdder, Citizens, CrazyAuctions, EssentialsChat, ASkyBlock-IslandBorder, Holograms, WorldGuard, Quests, CommandNPC, BeastWithdraw, EssentialsSpawn, TitleManager, SilkSpawners, CombatTagPlus, CrazyEnvoy, WildStacker, Duels, ShopGUIPlus, CrazyEnchantments, MFHoppers, SellChest, JetsMinions


    VIDEO OF THE ERROR:
     
  2. That's not caused by ASkyBlock. Look for unofficial addons that might have that feature.
     
  3. I just looked and deleted a few plugins and it still won't work.
     
  4. And also how do I bump a thread
     
  5. Reply to a thread and there's the bump.

    It may be due to fall damage, worldborder (most likely NOT)
     
  6. I don't think it is I just tried deleting Worldguard and resetting the regions but nothing.
     
  7. I do not know any of the plugins below, but based on their name, they might have some features that could cause this.

    CustomDrops, NoDeathMessage, HungerKeeperPlus, WorldBorder, SmartBans, DivineDrop, BountyHunters, SkyLevels2, ASkyBlock-IslandBorder, CombatTagPlus, Duels.
     
  8. Ok I have used all the plugins you have listed the whole time I have run my skyblock server and they have done nothing except for SkyLevels2 and I removed it from my server, restarted my server, and then tried to type /is once more and I still die. The thing is it only happens when I go the the ASkyBlock world and thats it just the skyblock world. So when I go ANYWHERE in the ASkyBlock world in SURVIVAL I die.
    I did remove HungerKeepPlus, Worldborder, DivineDrop, and ASKyBlock Island border and still nothing.
     
  9. You have a log? wow I never knew that, you get us to look at your log but yours is full of errors, do you even read it?

    upload_2020-2-6_22-50-23.png
    Probably the reason why it can't find so many biomes.
    Not a problem, but I get triggered.

    Did you download the correct version? This error spams your log everytime it starts successfully.
    Code (Text):


    [LIST=1]
    [*]org.apache.commons.lang.UnhandledException: Plugin WildStacker v3.0.1 generated an exception while executing task 3953
    [*]        at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:56)
    [*]        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    [*]        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    [*]        at java.lang.Thread.run(Unknown Source)
    [*]Caused by: java.lang.NoSuchMethodError: com.bgsoftware.wildstacker.api.objects.StackedEntity.getSpawnCause()Lcom/bgsoftware/wildstacker/api/enums/SpawnCause;
    [*]        at com.bgsoftware.wildstacker.utils.GeneralUtils.contains(GeneralUtils.java:14)
    [*]        at com.bgsoftware.wildstacker.objects.WStackedEntity.isBlacklisted(WStackedEntity.java:147)
    [*]        at com.bgsoftware.wildstacker.objects.WStackedEntity.isCached(WStackedEntity.java:636)
    [*]        at com.bgsoftware.wildstacker.handlers.SystemHandler.getStackedEntity(SystemHandler.java:115)
    [*]        at com.bgsoftware.wildstacker.objects.WStackedEntity.of(WStackedEntity.java:660)
    [*]        at com.bgsoftware.wildstacker.objects.WStackedEntity.of(WStackedEntity.java:653)
    [*]        at java.util.stream.ReferencePipeline$3$1.accept(Unknown Source)
    [*]        at java.util.stream.ReferencePipeline$2$1.accept(Unknown Source)
    [*]        at java.util.Spliterators$ArraySpliterator.forEachRemaining(Unknown Source)
    [*]        at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
    [*]        at java.util.stream.AbstractPipeline.wrapAndCopyInto(Unknown Source)
    [*]        at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(Unknown Source)
    [*]        at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(Unknown Source)
    [*]        at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
    [*]        at java.util.stream.ReferencePipeline.forEach(Unknown Source)
    [*]        at com.bgsoftware.wildstacker.listeners.ChunksListener.lambda$onChunkUnload$3(ChunksListener.java:47)
    [*]        at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71)
    [*]        at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    [*]        ... 3 more
     
    upload_2020-2-6_22-58-3.png
    Update Askyblock-IslandBorder.


    Update BountyHunters
    https://www.spigotmc.org/resources/40610


    Plugins don't just work, especially if your using BungeeCord:
    upload_2020-2-6_22-59-40.png



    Update Askyblock:
    upload_2020-2-6_23-0-15.png

    [/LIST]
     
  10. Are you using any Leaked Plugins?
     
  11. No I payed for all of them.
     
  12. First of all I contacted the author of WildStacker and fixed the error, I updated ASkyBlock, I removed Askyblock island border, I updated bounty hunters, I removed green houses and hungerkeepplus and I restarted my server. BUT I still keep dying. Now when you reply please be less triggered / angry.
     
  13. Are you sure? :)
    Code (Text):
    [17:41:18 INFO]: [SkyBlock Setup (S2)] - Leaked by TheNewLeaker_ | https://leakmania.com
     
    #15 Richard37, Feb 6, 2020
    Last edited: Feb 6, 2020
  14. Uninstall it and try then...
     
  15. I forgot I had that it is outa here.
     
  16. I told you I already removed it but I still keep dying
     
  17. Could you please send me log of console when you die?
     
  18. Thats the problem when I die I look in the console and there is nothing.