Spigot ExcellentEnchants - Vanilla-like enchantments! [1.15 - 1.17] 3.0.6.4a

Adds 40+ vanilla-like enchantments for your server!

  1. Thanks for making a free plugin for us all to enjoy! It's prob. not said enough but for my part I appreciate the time and effort it takes to make things like this compatible for everyone and every server.

    I do have an enchantment request if you're taking them: Flame Walker (similar to Frostwalker, except allowing player to walk on lava by replacing the lava block(s) around them with sand or some other acceptable block, then as the player moves away, it reverts back to original state.
     
  2. Is there a way to disable certain enchants to certain "ranks" on a server?
     
  3. Can you add option to increase maximum vanilla enchantment level? It would be really cool ! :D
     
  4. Does this already work for 1.16.2 if so I have a problem with Fcore that it doesnt work
     
  5. Seems that whenever someone gets hit with the rocket enchant and it's triggered, it flies them right up to the max build height and people get bugged out and stuck in the air and it makes the screen look all weird and glitchy.
     
  6. Hey so I play on a server, Weest.tv, and they use this resource pack. ive encountered a bug where if you repair a piece of gear using its corresponding item that is used to craft it (i.e. diamond armor being repaired with a diamond) the golden enchants stop working, it still says theyre on the armor however. also it gets removed if you try to combined two armors together with this bug active

    i dont use this site at all, I dont know how to submit bug reports so im putting this here. im prob not gunna remember to come back to check replied, i just thought i should try to let the creator know that i encountered this. have a nice day :)
     
  7. Hello, I installed your plugin a while ago. I really like it but I suddenly got a huge issue, when I updated the plugin it didn't turn on for some reason. Not that big of a deal right? So actually when I reinstalled the plugin again it just started like normal, but ALL enchants on ALL items in the game don't work anymore. Like: my sword has the enchant called Venom on it. But the enchant itself doesn't work anymore althought it's saying it has the enchant. All items on my server became useless...
     
  8. What about the 2 enchants in this plugin called: Rage and Vampire: do they give the effects to the player with the enchant or to the one you're hitting?
     
  9. Installed and restarted server twice. Somehow not in the server. I can see it in the files, but there are no extra enchantments or commands.
     
  10. thanks that is perfect i just dont know how to set loot tables @TekaHD
     
  11. thanks dude its perfect and easy to edit
     
  12. Maybe thunder enchant? (if you hit someone with an arrow he'll get struck by lightning)
    Idk if I already suggested but: Criticals, (for swords and axes, criticals will deal even more damage)
     
  13. the foguscore jar doesn't seem to be working while the goldenenchants one is. how i get the other working????
     
  14. When an enchanting book has both original enchanting + plug-in enchanting
    Can you come up with a mechanism to remove the original enchantment from the enchanted book? (Only the plug-in enchanting remains)

    Because the original enchantment would interfere with the "originally set weapon enchantment level"
     
  15. The other thing is that one of the enchants in the plug-in is to kill monsters to drop a skull.
    I'd like the dropped skulls to be saved on the server.
    When I have different and large numbers of skulls in the case, it's quite LAG when I open the case.
     
  16. Will do

    Could you give me some examples? I don't understand it.

    It's because spigot loads head textures when you open it. Not a plugin issue.
     
  17. Just a heads up, not compatible with freerpg in 1.16.2 (unless enchanting skill is disabled) if anyone was experiencing an issue (enchantments do now show up when enchanting from the enchanting table).
     
  18. Plugin fails to load


    I am running a fully up-to-date Spigot 1.16.1 server with no other plugins on it.
    I am using version 2.6.7.1 of the Plugin.
    The plugin never seems to enable, seemingly because FogusCore disables itself immediately after Enabling.


    [12:47:51] [Server thread/INFO]: [FogusCore] Loading FogusCore v1.9.9
    [12:47:51] [Server thread/INFO]: [GoldenEnchants] Loading GoldenEnchants v2.6.7.1
    [12:47:51] [Server thread/INFO]: [FogusCore] Enabling FogusCore v1.9.9
    [12:47:51] [Server thread/INFO]: [FogusCore] Disabling FogusCore v1.9.9
    [12:47:51] [Server thread/INFO]: [GoldenEnchants] Enabling GoldenEnchants v2.6.7.1
    [12:47:51] [Server thread/INFO]: [GoldenEnchants] Powered by: FogusCore
    [12:47:51] [Server thread/ERROR]: Error occurred while enabling GoldenEnchants v2.6.7.1 (Is it up to date?)
    java.lang.NullPointerException: null
    at su.fogus.engine.utils.StringUT.colorFix(StringUT.java:35) ~[?:?]
    at su.fogus.engine.utils.StringUT.color(StringUT.java:30) ~[?:?]
    at su.fogus.engine.config.api.IConfigTemplate.setup(IConfigTemplate.java:42) ~[?:?]
    at su.nightexpress.goldenenchants.GoldenEnchants.setConfig(GoldenEnchants.java:50) ~[?:?]
    at su.fogus.engine.config.ConfigManager.setup(ConfigManager.java:32) ~[?:?]
    at su.fogus.engine.FogusPlugin.loadManagers(FogusPlugin.java:209) ~[?:?]
    at su.fogus.engine.FogusPlugin.onEnable(FogusPlugin.java:102) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:351) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:480) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugin(CraftServer.java:493) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugins(CraftServer.java:407) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at net.minecraft.server.v1_16_R1.DedicatedServer.init(DedicatedServer.java:187) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at net.minecraft.server.v1_16_R1.MinecraftServer.v(MinecraftServer.java:810) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at net.minecraft.server.v1_16_R1.MinecraftServer.lambda$0(MinecraftServer.java:164) ~[spigot-1.16.1.jar:git-Spigot-9639cf7-4b9bc9d]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_251]