1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Crash Exception in thread "Craft Scheduler Thread - 1"

Discussion in 'Bugs & Feature Requests' started by curley, Feb 26, 2013.

  1. I recieved this error in the console right before a crash when attempting to run my server on #575 build of spigot.

    Here is the entire server.log from boot to crash.

    http://pastebin.com/tAK2J3pv

    There is no minecraft crash report generated as after the final line there the terminal stops responding and the processer usage go to 100%. Attempting to ctrl-c causes a response from the jvm stating the process must be killed. After killing java the terminal and cpu return to normal.

    Loading the server back the with current RB of craftbukkit loads up without an issue so far and has been running for about 3 hours now.

    Prior to trying the #575 build of spigot I tried running my server on the RB build and while it did stay up longer than a few seconds after about an hour of running the same error was generated without much of a reason. In that case, again there was no mc crash generated and the terminal locked with cpu at 100%. recreated 3 times after different intervals of running before I tried the most recent (#575) build of spigot. Not sure where to begin looking.

    for sake of it here's my plugin list:
    Plugins (40): TuxTwoLib, LagMeter, MultiInv, WorldEdit, NoCheatPlus, SilkierTouch, ShiftMode, Vault, Multiverse-Core, PermissionsEx, Wither, LogBlock, SelfPromote, WorldGuard, ColoredTablist, ModReq, AutoMessage, iConomy, ProperTime, Permissions, CommandHelper, AdvancedBans, ProtocolLib, Modifyworld, PlayerSkulls, Herochat, MobEggs, CleanroomGenerator, Essentials, RegionForSale, TagAPI, Multiverse-SignPortals, Multiverse-NetherPortals, SignShop, LWC, dynmap, MonsterIRC, CraftBook, WorldBorder, VanishNoPacket

    Thanks for any help you guys can provide.
     
  2. Puremin0rez

    Moderator

    Interesting... I see a "java.lang.OutOfMemoryError: PermGen space" which means you might be running out of Perm Gen Space.

    Try adding "-XX:MaxPermSize=256m" to your startup script and see if your any better.

    I've had this issue with McMMO (since it's a pretty heavy plugin) and doing the above step helped solve my issues.

    Good Luck
     
  3. SuperSpyTX

    Supporter

    I had a PermGen space error before.

    Are you using /reload? If so, ProtocolLib is the cultprit. Using /reload several times with ProtocolLib causes a PermGen error and freezes the server.
     
  4. thanks puremin0rez, I'll definitely give that a shot when i get home tonight and post back with results.

    to superspytx, This error log is right at initial boot and there error i spoke of previously was after 30 or so minutes of running without users on. I never use /reload, long time user of PEX and early on in my admining it was beaten into me to never even bother using it ^_^
     
  5. You should never use reload even if you dont have pex. But as SuperSpyTX said protocollib can cause this, It caused it on my server even without using reload. Increasing to -XX:MaxPermSize=512m fixed it for me. 256m is probably enough though.
     
  6. permgen is section of memory that is NEVER freed until process close...

    Strings i believe are always put in permgen.. So if a plugin uses tons of strings, it will chew up alot of permgen.

    Reload then readds yet another batch of strings, so that causes it to run out quicker.

    raising limit is the only solution to this problem.