Spigot Extra Hard Mode 3.15.0-e4f17b1

Deliver interesting new challenges for advanced players

  1. SlimeDog

    Moderator Patron

    A. The plugin is in maintenance mode, so you should not expect major changes or fixes.
    B. Please post bugs as Github issues rather than discussion items.
     
    • Like Like x 1
  2. Hi, apparently artifacts are automatically deleted if they are older than one month. Is there another way to download it?
     
  3. SlimeDog

    Moderator Patron

    No. The latest sources I am aware of are https://github.com/MLG-Fortress/ExtraHardMode, so you could build it yourself.

    I suggest you communicate with RoboMWM and ask him to refresh the build artifact. Sigh ...
     
    • Like Like x 1
  4. for others attempting to communicate with RoboMWM, their discord invite: discord.gg/a5F2TvUpEa
     
    • Friendly Friendly x 1
  5. Slowly trying to get back into MC stuff. First order of business is getting a server going again so I have a reason to actually use these plugins lol.

    if dev build was working I'll just release that.
     
    • Like Like x 2
    • Agree Agree x 1
  6. SlimeDog

    Moderator Patron

    In my admittedly-limited configuration, ExtraHardMode-3.15.0-b178 works fine on Spigot/Paper 1.18.1 and 1.18.2.
     
    • Informative Informative x 1
  7. RoboMWM updated Extra Hard Mode with a new update entry:

    3.15.0-e4f17b1

    Read the rest of this update entry...
     
    • Like Like x 2
  8. SlimeDog

    Moderator Patron

    • Informative Informative x 1
  9. SlimeDog

    Moderator Patron

    Paper 1.18.2-277
    ExtraHardMode 3.15.0-b179

    On server start-up
    Code (Text):
    [10:58:23] [Server thread/WARN]: @EventHandler method com.extrahardmode.features.AntiGrinder#onEntityDeath returns non-void type boolean. This is unsupported behavior and will no longer work in a future version of Paper. This should be reported to the developers of ExtraHardMode v3.15.0-e4f17b1 (RoboMWM,Diemex,Big_Scary)
    [10:58:23] [Server thread/WARN]: @EventHandler method com.extrahardmode.features.AntiGrinder#onEntitySpawn returns non-void type boolean. This is unsupported behavior and will no longer work in a future version of Paper. This should be reported to the developers of ExtraHardMode v3.15.0-e4f17b1 (RoboMWM,Diemex,Big_Scary)
     
    • Useful Useful x 1
  10. Interesting, I wonder why that is (that it is unsupported).
     
    • Optimistic Optimistic x 1
  11. SlimeDog

    Moderator Patron

    Paper <> Spigot
     
    • Informative Informative x 1
  12. RoboMWM updated Extra Hard Mode with a new update entry:

    3.15.0-e4f17b1

    Read the rest of this update entry...
     
    • Winner Winner x 2
  13. I guess I should've doublechecked that the update here I made on spigot was to the right file... Whoops. I saw slimedog hint at it in another post but I didn't really pay attention to it.
     
    • Informative Informative x 1
  14. Hello! I installed the plugin today.. really looks very interesting. I just cant seem to get it to work in only certain world. I tried a few ways. At the moment it looks like this. After reloading it says "EHM is enabled for all world", but Im not even sure how to test if its actually just in these 3 worlds. Please help?

    upload_2022-4-11_3-45-17.png
     
  15. SlimeDog

    Moderator Patron

    Code (Text):
    >ehm help
    [18:54:50] [Server thread/INFO]: ========= ExtraHardMode =========
    [18:54:50] [Server thread/INFO]:  /ehm
    [18:54:50] [Server thread/INFO]:     help - Show the help menu
    [18:54:50] [Server thread/INFO]:     version - Show version info
    [18:54:50] [Server thread/INFO]:     reload - Reload the plugin
    [18:54:50] [Server thread/INFO]:     enabled [world]- Is extrahardmode enabled
    >ehm enabled world
    [18:58:00] [Server thread/INFO]: EHM enabled for: [...]
    [18:58:00] [Server thread/INFO]: EHM disabled for: [...]
    [18:58:00] [Server thread/INFO]: Current world: world disabled
     
  16. This didnt really answer my question. I would like to know the format to actually enable the worlds properly.

    This is what I get if I run ehm help in console. Just this.

    upload_2022-4-11_15-44-56.png

    And I dont want [world] enabled and neither did I enable it.
     
  17. SlimeDog

    Moderator Patron

    The configuration file is pretty well documented internally. At the top of config.yml
    Code (Text):
    ExtraHardMode:
      Config Type: MAIN
      # If the big text on top of the config should be printed
      Print Config Header: true
      # If comments like this should be printed
      Print Comments: true
      # Set the worlds you want ehm active here. E.g. [world, world_nether]. "@all" enables ehm for all worlds
      Enabled Worlds:
      - world_first_enabled_world
      - world_second_enabled_world
    ...
    Note that by default the world list is @ all. I have indicated above how to set it for specific worlds.

    Then restart the server, and run ehm enabled world to verify which worlds are enabled and disabled.
     
    • Like Like x 1