Extremely low mob spawns

Discussion in 'Performance Tweaking' started by Kainzo, Jan 27, 2013.

  1. Here's teh bukkit.yml

    I moved from a very old build (Around Jan 4th) to today's latest and the mob spawns for 80 players online went from 2500 to 500 in one world.

    I tested by doing /wg report -p and /butcher (no passives)
    Is there some setting that is now working that would affect this?
    Code (Text):
    # This is the main configuration file for Bukkit.
    # As you can see, there's actually not that much to configure without any plugins.
    # For a reference for any variable inside this file, check out the bukkit wiki at
    # http://wiki.bukkit.org/Bukkit.yml
    settings:
      allow-end: false
      warn-on-overload: false
      permissions-file: permissions.yml
      update-folder: update
      ping-packet-limit: 100
      use-exact-login-location: false
      plugin-profiling: true
      connection-throttle: 0
      query-plugins: false
      deprecated-verbose: default
      shutdown-message: Server closed
      restart-script-location: start.bat
      timeout-time: 200
      restart-on-crash: false
      filter-unsafe-ips: false
      whitelist-message: Net Issues! Be patient!
      log-commands: false
      command-complete: true
      spam-exclusions:
      - /skill
      stop-message: Server restarting! Brb
    world-settings:
      default:
        growth-chunks-per-tick: 350
        mob-spawn-range: 2
        item-merge-radius: 4
        exp-merge-radius: 3
        random-light-updates: false
        aggregate-chunkticks: 4
        wheat-growth-modifier: 95
        cactus-growth-modifier: 95
        melon-growth-modifier: 95
        pumpkin-growth-modifier: 95
        sugar-growth-modifier: 95
        tree-growth-modifier: 150
        mushroom-growth-modifier: 55
      world:
        growth-chunks-per-tick: 1000
      world_nether:
        view-distance: 5
        growth-chunks-per-tick: 0
        random-light-updates: true
        water-creatures-per-chunk: 0
      forgelight:
        view-distance: 4
        growth-chunks-per-tick: 650
        water-creatures-per-chunk: 1
        random-light-updates: false
      hell:
        view-distance: 4
        growth-chunks-per-tick: 0
        random-light-updates: false
        water-creatures-per-chunk: 0
      lostcove:
        view-distance: 7
        growth-chunks-per-tick: 0
        random-light-updates: false
        water-creatures-per-chunk: 0
      bastion:
        growth-chunks-per-tick: 400
        water-creatures-per-chunk: 1
        random-light-updates: false
      warshard:
        view-distance: 4
        growth-chunks-per-tick: 0
        random-light-updates: false
        water-creatures-per-chunk: 0
    spawn-limits:
      monsters: 180
      animals: 13
      water-animals: 1
      ambient: 2
    chunk-gc:
      period-in-ticks: 600
      load-threshold: 0
    ticks-per:
      animal-spawns: 400
      monster-spawns: 10
      autosave: 0
    auto-updater:
      enabled: false
      on-broken:
      - warn-console
      - warn-ops
      on-update:
      - warn-console
      - warn-ops
      preferred-channel: rb
      host: dl.bukkitpp.org
      suggest-channels: false
    database:
      username: bukkit
      isolation: SERIALIZABLE
      driver: org.sqlite.JDBC
      password: walrus
      url: jdbc:sqlite:{DIR}{NAME}.db
    orebfuscator:
      enable: true
      update-radius: 2
      disabled-worlds:
      - hell
      - lostcove
    storm-settings:
      strong-electrical-storm:
        chance: 0
        lightning-delay: 50
        lightning-random-delay: 200
      electrical-storm:
        chance: 0
        lightning-delay: 60
        lightning-random-delay: 250
      strong-thunderstorm:
        chance: 0
        lightning-delay: 60
        lightning-random-delay: 250
      thunderstorm:
        chance: 0
        lightning-delay: 100
        lightning-random-delay: 500
      weak-thunderstorm:
        chance: 0
        lightning-delay: 300
        lightning-random-delay: 1000
      rainstorm:
        chance: 1
        lightning-delay: 500
        lightning-random-delay: 2000
     
  2. LiLChris

    LiLChris Retired Moderator
    Retired

    Have the same issue...
    http://www.spigotmc.org/threads/mob-spawning.65/#post-3982

    I now have:
    Code (Text):
    spawn-limits:
      monsters: 75
      animals: 5
      water-animals: 1
      ambient: 1
    ticks-per:
      animal-spawns: 400
      monster-spawns: 1
    With 70 players, only about 354 mobs...


    It's players only source of income, so they notice when spawn rates are low too. :(
     
  3. Good to know, thanks... hoping to find some temp-fix cause its really unplayable for RPG servers.
     
  4. If you go the settings route you can increase the mob-spawn-range to 8 and go with view-distances near 8 for best results. It's not very performance friendly but you can tweak the other settings as needed.

    Or just make a simple plugin to cancel Natural Monster Spawns (not including dragons) at a specific distance.....
    We have been running a plugin that simply cancels Natural Spawns (excluding Dragons) around a specific distance. It's really nothing special but works.

    With my plugin the 2 main settings don't really matter; because I set the exact distance (in blocks) that Monsters can spawn.
     
  5. LiLChris

    LiLChris Retired Moderator
    Retired

    That shouldn't be needed, it was working fine before.
    I just wish I knew which version, but I really want to keep the anti-xray so hope the bug is found. :)
     
  6. I agree it shouldn't be needed.
     
  7. While this is may work - it defeats the purpose of having low-view distance. We cant have 200 players online and keep view distance at 8.
     
  8. md_5

    Administrator Developer

    I'm going to revert out changes to spawning this afternoon, but they shouldn't affect anyone with a view distance of 7 or higher.
     
    • Like Like x 1
  9. LiLChris

    LiLChris Retired Moderator
    Retired

    Thanks! :)
     
  10. Yep, that's why I said it wouldn't be performance friendly. You wanted a temp fix....

    Just glad md_5 has some time to work on this issue, I know he's been busy with BungeeCord.
     
  11. This problem still seems to be around, anyone else noticing that as well?
     
  12. Ive been plauged with this for a couple weeks now. Ive updated spigot to newer dev builds to be certain it wasnt the issue.
    Currently running spigot 806
    bukkit,yml
    mob-spawn-range: 5
    spawn-limits:
    monsters: 130
    animals: 20
    water-animals: 5
    ambient: 15
    chunk-gc:
    period-in-ticks: 600
    load-threshold: 0
    ticks-per:
    animal-spawns: 400
    monster-spawns: 20
    autosave: 0
    Havent really modified much else in bukkit.yml
    Ive removed any plugins which would mess with spawn rates like nolagg, clearlag, lagmeter (which shouldnt affect spawns at all anyway), and more..
    current plugins
    Code (Text):
    Autorank.jar            MasterPromote.jar                Register.jar
    AutoSaveWorld.jar        MCBans-v4.2.jar                  ReportRTS.jar
    bpermissions.jar        mcMMO.jar                        TagAPI.jar
    ChestShop.jar            Minequery.jar                    TerrainControl.jar
    Citizens.jar            Multiverse-Core-2.5.jar          Towny.jar
    cncp.jar                Multiverse-Inventories-2.5.jar    uIRCBridge.jar
    CraftIRC.jar            Multiverse-NetherPortals-2.5.jar  VanishNoPacket.jar
    DisguiseCraft.jar        Multiverse-Portals-2.5.jar        Vault.jar
    dynmap.jar              NameTags.jar                      Votifier.jar
    EssentialsAntiBuild.jar  NoCheatPlus.jar                  WorldBorder.jar
    Essentials.jar          OnTime.jar                        WorldEdit.jar
    EssentialsSpawn.jar      PlayerHeads.jar                  WorldGuard.jar
    Herochat.jar            Prism.jar                        XBP-v1.9.2.jar
    JSONAPI.jar              ProtocolLib-2.4.1.jar
    LWC.jar                  Questioner.jar
     
    When I first start the server, spawns seem to be fine, but after about 5 mins, next to nothing. Sitting outside in the dark for 5 nights, saw 4 mobs.
    I have all difficulties set to 3 in server properties and hard for multiverse. Ive been beating my head over this for weeks.. any ideas?
     
    #12 fffizzz, Apr 23, 2013
    Last edited: Apr 23, 2013
  13. What we could really use is a mobcap improvement option like what the JL2579 ZipKrowd crew came up with.

     
  14. seems like a great thing
     
  15. So, went back to latest beta build of CB, and mob spawns seem to be working properly now.

    Just thought I'd share.
     
  16. joehot200

    Supporter

    I coded a plugin that every 2.5 minutes clears all the mobs.
    Not very good, i know, but certainly balances thing about.
    Problem for me, is if i use my ninjas plugin, then it takes people even with full diamond armour at least 3 mins to kill one, which can be a problem...
     
  17. This wont fix the issue... it may mask it sometimes but that's a very bad fix imo...
    Correct - this is a change done with the mob-spawn radius, you have to massively (x2) increase the spawn amount in order to keep the spawn radius at 4.
     
  18. I'm having a problem that at night no hostile mobs spawn naturally. They would only spawn via mob spawners and spawn eggs
     
  19. Sudzzy

    Patron

    Dat necropost
     
  20. I was going to reply x'D