Extremely Weird Crash During Startup

Discussion in 'Systems Administration' started by CaptainEnderDude, Sep 14, 2019 at 1:35 AM.

  1. Hello all!

    Recently some of our servers on our network have been having issues starting up. They load up fine up until a certain point, and then they stall and these errors start to appear:

    https://paste.md-5.net/masewebuba.shell

    In the case of the server above, it was fixed "on its own" during one of our attempts of booting the server up. This issue is very erratic as it occurs only after some restarts, and sometimes on multiple servers at the same time, but sometimes on just one. We've tried eliminating certain plugins that we thought may have been culprits in this issue, restarting our database servers, and even as far as restarting the dedicated machine in an attempt to fix this. However, none of our actions seemed to have a direct correlation with fixing the issue.

    We are not sure what to focus on at this point, so any input is highly appreciated!

    Thank you.
     
  2. What happens to the server? Is the server lagging or crashing?
     
  3. It's in a crashed state, no one can join and the rest of the plugins don't load up.
     
  4. I've found that "Your server has been detected having 0 TPS 4 times a row";
    That could be caused by the gamerule of "RandomTickSpeed".
    I really don't if you are working with that, but if you are set it lower.

    Question: What version are you using? Spigot 1.8? 1.14?
     
  5. 1.14.

    I checked, and all the world gamerules for RandomTickSpeed are set to the default of 3.
     
  6. Guys anyone have any other suggestions on what this could be?
     
  7. [18:06:07] [pool-83-thread-1/INFO]: [ TPS Meter ] The server's TPS is bellow 0.0, is it lagging or crashed?

    Your server has been detected having 0 TPS 4 times a row, which means that with high probability it crashed / frozen down. This crash report will help for your developers to detect what's causing the crash. This is NOT an error in SpigotLib, but it's one of it's features, so only contact gyuriX for fixing the error caused this crash if you can pay for it.

    Try removing all unneeded plugins. It's most likely once of your plugins causing your server to timeout.