Spigot Factions 1.8.2 UUID 1.8.2-U0.7

Factions 1.8.2 UUID Support - No MCore

  1. externo6

    Supporter

    externo6 submitted a new resource:

    Factions 1.8.2 UUID - Factions 1.8.2 UUID Support

    Read more about this resource...
     
    • Winner Winner x 4
    • Agree Agree x 1
  2. Omg thank you
     
    • Like Like x 1
  3. LiLChris

    LiLChris Retired Moderator
    Retired

    Thank you! :)
    Making a backup to test it.


    So it moved players.json to players.json.old, but now there is no players in it.
    Players seem to be able to join a Faction but can't /f leave or /f who.

    Also an error showing up.
     
    #3 LiLChris, Sep 12, 2014
    Last edited: Sep 12, 2014
  4. externo6

    Supporter

    What version of vault do you have?
    It requires v1.4.1

    Ill look into the players.json

    Edit*

    In all my tests it worked fine, would you mind sending me your factions plugin folder?
    Can you try running /f save after the server has started, this should then save all faction data back to the disk as it does not do this automatically

    Updated the resource info to reflect this.

    Thanks! :)
     
    #4 externo6, Sep 12, 2014
    Last edited: Sep 12, 2014
    • Informative Informative x 1
  5. Yup all my player files were whipped too.
     
  6. externo6

    Supporter

    Please try a /f save after it has converted. It may not have saved the files right after the conversion.
    If this does not bring them back, ill do some further testing.
     
  7. externo6

    Supporter

  8. Would this screw with all the factions if i added this in replacing the latest factions?
     
  9. externo6

    Supporter

    This is only compatible with 1.8.2 factions. I cannot provide support for other versions.
     
  10. Thank you :) I have the non-uuid factions v1.8.2 on my server right now. If I upload this, no data will be lost, correct? Everything will be the same but with UUID support?
     
  11. externo6

    Supporter

    Yes that is correct, though there maybe bugs so please report any issues you have. Make sure you backup your data before hand :)
     
    • Useful Useful x 1
  12. so this is 1.6.9.5 but uuid support?
     
  13. externo6

    Supporter

    No, it clearly states 1.8.2
     
  14. externo6

    Supporter

    No..
    Notes
    • This is only for Factions 1.8.2!
     
    • Funny Funny x 1
  15. 1.8. Good job @externo6. I'm sure the community will find this useful.
     
    • Like Like x 1
  16. externo6

    Supporter

    Thank you :)
     
    • Agree Agree x 1
  17. I'm looking but what are the perms for this?...In case someone beats me to it EDIT: nvrmind..found them in the jar...Duh!
     
    • Like Like x 1
  18. externo6

    Supporter

    • Like Like x 1
  19. I never did use 1.8.2, I had 2.5 but I think it is great! How does the cape work?