Factions v1.6.9.4 + PaperSpigot-1.8.8-R0.1

Discussion in 'Spigot Plugin Help' started by xIcey, Apr 24, 2017.

  1. Hello!
    I am adding a factions server to my network, and I got everything to work perfectly beside the factions plugin itself. I am using Factions version 1.6.9.4 (a really old version) and paper spigot 1.8.8 r0.1 latest. Factions does work with regular 1.8 spigot, but not with paper spigot. Here is the error message.

    Code (Text):
    [15:53:27 INFO]: [Factions] Enabling Factions v1.6.9.4
    [15:53:27 ERROR]: [Factions v1.6.9.4] GSON lib not found. Your CraftBukkit build is too old (< 1.3.2) or otherwise not compatible.
    [15:53:27 INFO]: [Factions v1.6.9.4] Now I suicide!
    [15:53:27 INFO]: [Factions] Disabling Factions v1.6.9.4
    [15:53:27 INFO]: [Lockette] Disabled link to plugin Factions, version 1.6.9.4
    [15:53:27 INFO]: [Factions v1.6.9.4] Disabled
     
    Why I need an old version of factions:
    The version of factions I am using has the old faction chat command and a better claim function. Instead of /f claim one, it's just the simple /f claim. It makes it much easier for players.

    Why I need paper spigot and not regular spigot (both for 1.8):
    Paperspigot allows me to change cannoning mechanics to the preferred 1.7 mechanics.

    Is there an alternative version for paper spigot (still working with Minecraft 1.8) or factions (still with f chat and f claim)? I have been trying to find an alternative factions version, but it's just not working.

    Link to paper spigot (Currently Using PaperSpigot-1.8.8-R0.1-SNAPSHOT-latest.jar (1.8.8) (18.96MB) (March 6, 2016))
    Link to factions files (Currently using v1.6.9.4 located at the bottom of page 2)

    I appreciate any help!
    - IXED
     
    • Agree Agree x 1