Spigot Factions 2.14.0

Create your Faction, Claim your Land, Fight your Enemies!

  1. NCF

    NCF

    somewhere in one of the threads a month or 2 ago cayorion stated he expected it could take near 6 months before he updates massivecore plugins to 1.13.X. I wish i could quote the post, and more so wish i was wrong. i am not fond of the other faction alternatives i have tried- and i also had used massive books, massivelag, and the dynmap extension all in parallel with massivefactions, so i am really hoping im wrong.

    i also found in my personal experience he isnt the fastest to reply in these threads so dont be checkin here daily or youll just get upset and anxious. consider alternatives

    edit pasted from front page
    "

    fantahund99

    Version: 2.14.0When will this plugin be updated to Minecraft version 1.13?
    ================================================
    Aug 8, 2018
    1. [​IMG]
      Author's Response
      I will confess the update to 1.13 is going to be slow for the MassiveCraft plugins. It may take us 3-6 months to perform the update, sorry. But I want to be transparent about this so that you can plan your server upgrades accordingly.
     
    • Informative Informative x 1
  2. It does not matter I've fixed it, I've updated and reprogrammed all the factions code and I have it running at 1.13.1 for my, everything seems to work perfectly xD if at any time update the complement and do it right and I will change it but for now what I have programmed is perfect for me thanks for your comments xD
     
  3. u can make upgrade faction ?
     
  4. if I have already done it for me for my server, only for 1.13.1 etc.
     
  5. Hi, I would like to know if the faction plugin has any incompatibility problem with some of these plugins:

    Plugins (52): Lift, NametagEdit, CustomRecipes, SkinsRestorer, ChatColor, AsyncWorldEditInjector, TabListEdit, FastCraft, PEX-Rankup, ClearLag, BileTools, Elevator, ProtocolLib, Multiverse-Core, MVdWPlaceholderAPI, AsyncWorldEdit, PermissionsEx, FeatherBoard, Vault, MassiveCore, EpicRename, HolographicDisplays, ItemStay, AuctionHouse, ChestCommands, RandomTeleport, WorldEdit, Essentials, Jobs, BuycraftX, KitAdder, Citizens, Shopkeepers, EssentialsChat, TreeAssist, MineResetLite, WorldGuard, EssentialsProtect, EssentialsGeoIP, EssentialsAntiBuild, CommandNPC, EssentialsSpawn, CustomEnchantments, CrateReloaded, FramePicture, ProtectionStones, AuthMe, Factions, LeaderHeads, MyPet, CustomBosses, SilkSpawners

    When I start I get an error in the console:

    https://pastebin.com/qM8G88fS
     
    #1145 ByEmax, Oct 26, 2018
    Last edited: Oct 26, 2018
  6. Hey everyone,

    first of all, thanks for this wonderful Plugin it has been an essential part of our server over the years.

    But of corse I'm not just here to say thanks and sneak away, sadly we are having a severe problem with Factions under 1.12.2:
    Herochat and Factions don't seem to work together anymore and according to the Herochat Plugin Thread I am not the only one with this issue. This is bad because the Faction and Ally Chat Features really were essential to lots of rp servers using factions.

    So I messaged the Herochat Devs and they said:
    "This is undoubtedly a factions issue. We are a chat plugin, they are a war plugin, they should be hooking into our API."
    Well thats not helping, so now I'm here.

    My first question would be:
    Is anyone using Factions and Herochat OR Factions an an alternative Chat Plugin that can limit the Channel Radius successfully together under 1.12.2?

    If there is a fix for the Herochat-Factions Hook, i'll leave the report I sent to the Herochat team:

    We are using the newest Hero Chat build 6.0.1 b31 but tried older versions with the same result. The Issue comes up when we try to employ Hero Chat and Factions / Massivecore together. (Version 2.14.0)
    Our Server runs on Spigot 1.12.2.

    On joining the Factions or Allies Channel via /ch F /ch A the chat shows an internal Server Error and the following Errors show up in the console:

    Code (Text):
    [05:58:51 ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'ch' in plugin Herochat v6.0.1-SNAPSHOT-bb31
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:651) ~[craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.PlayerConnection.handleCommand(PlayerConnection.java:1392) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1227) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_151]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_151]
    at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:748) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:679) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:577) [craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]
    Caused by: java.lang.NullPointerException
    at com.dthielke.herochat.command.commands.QuickMsgCommand.execute(QuickMsgCommand.java:57) ~[?:?]
    at com.dthielke.herochat.command.CommandHandler.dispatch(CommandHandler.java:56) ~[?:?]
    at com.dthielke.herochat.Herochat.onCommand(Herochat.java:88) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[craftbukkit.jar:git-Spigot-7754231-9a1f5ee]
    ... 15 more
    Several other people seem to have the same problem according to this thread: https://www.spigotmc.org/threads/he...re-75-off-for-1-13-update-paid.207864/page-10

    We have been using Herochat and Factions for over 2 Years on our 1.10 Server, this only happens with the "pay version" of Herochat under 1.12.

    When I reload herochat via /herochat reload the error stops appearing but Factions does not recognize the Factions or Allies Channels and the just behave like a different Global Chat, for everyone to read, no matter what faction they are joined. The Error then reappears after every Server restart.

    I'd be glad to post more Info if needed or discuss this in the Herochat supportthread but my post there does not seem to get answered.

    Thanks for any help and have a nice week :)
     
    • Optimistic Optimistic x 1
  7. Factions do not work in 1.12.2
     

    Attached Files:

  8. update 1.13.2 please
     
  9. probably won't happen, you need to switch to one of the other factions forks or run a 1.8-1.12 server

    The main developer no longer codes and the other devs are struggling to make money from the massivecraft factions server.

    Honestly, I think they should put this up for sale in the premium section and generate some funds to help support the project.
     
    • Like Like x 1
  10. read my post above.
     
  11. Hello,

    Is there a way to set the price of buying factions chunks to increase the more you buy.

    example first chunk is $100
    config option like
    Code (Text):
    price-change: 1.20
    that would increase the cost by 20% of the previous chunk
    1 chunk = 100
    2 chunks = 120
    3 chunks = 144
    4 = 173
    5 = 207
    6 = 249
    7 = 299
    8 = 358
    9 = 430
    ... etc

    Thanks.
     
  12. Hi, im getting some errors on Factions /f f command
    It think it is cuz of the Economy system.
    https://pastebin.com/Ga18P7k1
    Im using Gringotts for money plugin
     
    • Like Like x 1
  13. nice plugin, i do have an question. I want to change my /f home teleport delay to 3 seconds instead of 10 seconds. I use faction 2.14. Nowhere in the config i can find an option to change this, please help me!
     
  14. Look for this in:
    Code (Text):
      "permissionToTpdelay": {
        "massivecore.notpdelay": 0,
        "default": 10
      },
     
  15. Please update this plugin for 1.13 or at least fix the Integration Activation IntegrationWorldGuard FAILED error the keeps spamming console.
     
    • Agree Agree x 1
  16. NCF

    NCF

    here you are
     
  17. Thanks dude! I will certainly try this out.
     
  18. i already looked for this, its nowhere to be found in 2.14 mcore factions config