Solved FactionsTop wont work

Discussion in 'Spigot Plugin Help' started by 09TheMobLordXx, Mar 19, 2020.

  1. Plugin Link: https://www.spigotmc.org/resources/f-top-factions-top-by-novucs.26905/
    Factions I am using: FactionsUUID
    My server version: 1.8.1

    ERROR
    Code (Text):
    [12:38:21 INFO]: [FactionsTop] Enabling FactionsTop v1.2.0
    [12:38:21 INFO]: [FactionsTop] Essentials found, using as economy backend.
    [12:38:21 ERROR]: Error occurred while enabling FactionsTop v1.2.0 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/massivecraft/factions/zcore/persist/MemoryBoard
            at net.novucs.ftop.hook.Factions0106.initialize(Factions0106.java:42) ~[?:?]
            at java.lang.Iterable.forEach(Unknown Source) ~[?:1.8.0_231]
            at net.novucs.ftop.FactionsTopPlugin.loadSettings(FactionsTopPlugin.java:371) ~[?:?]
            at net.novucs.ftop.FactionsTopPlugin.onEnable(FactionsTopPlugin.java:138) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_231]
    Caused by: java.lang.ClassNotFoundException: com.massivecraft.factions.zcore.persist.MemoryBoard
            at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_231]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-db6de12-d3e0b6f]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
            ... 15 more
    Please this is my only FactionsTop Plugin! I need this to work.
     
  2. I doubt we can do anything honestly.
    It's either:
    The version you are using is not supported.
    OR
    Something went wrong on the dev's part. (I doubt so, it seems to work for many other people)

    We can't do anything with this, this states that a class is missing while the plugin is running.
    Try contacting the plugin author.
     
  3. Awee rip this is the only stop plugin ik that has a GUI
     
  4. Have you tried this one? This works with FactionsUUID.
    https://www.spigotmc.org/resources/factions-top-1-7-1-15-f-top-factionsuuid-saberfactions.20661/