1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Crash Failed to bind to port

Discussion in 'Bugs & Feature Requests' started by yusiang1998, Apr 2, 2013.

  1. http://pastebin.com/ZBghPhfA

    Using OPENJDK-7-JRE-HEADLESS
    for ARMv6 HF (Raspbian)
    I've tried putting an IP address and changing the port in server.properties, but same result.
    I was hoping that spigot would get me at least a basic server running with the spare 256MB-384MB of ram i have on my raspberrypi. Ah well.
     
  2. jeff142

    Benefactor

    do you have a diffrent instance of the server runing?
     
  3. Nope, only the one. Is it something to do with openjdk?
     
  4. jeff142

    Benefactor

    only time i have had this happen is if a diffrent instance binded to the port
     
  5. Have you tried restarting the Pi?
     
  6. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Kill whatever is using the port 25563.
     
  7. md_5

    Administrator Developer

    • Useful Useful x 1
  8. Hey it worked! Thanks!
    ( If i didn't specify what IT is, it was disabling netty.)
     
    #8 yusiang1998, Apr 3, 2013
    Last edited: Apr 3, 2013
  9. Failed to bind port- how would you dissable netty?
     
  10. I'm having this issue too...

    Port is failing to bind, but there is nothing else running on it. I was relieved to find out someone had the same issue that was resolved, but then I realized this post is from 2013. There is no more netty option...

    Is there any other fix? :(
    @md_5