Failed to bind to port

Discussion in 'Spigot Help' started by Fire_Kehan, Jun 19, 2021.

  1. I researched to fix this problem and nothing helped i changed the port, i closed all java, and i rebooted my pc and nothing worked. the error i got was:
    [16:30:14] [main/INFO]: Environment: authHost='https://authserver.mojang.com', accountsHost='https://api.mojang.com', sessionHost='https://sessionserver.mojang.com', servicesHost='https://api.minecraftservices.com', name='PROD'
    [16:30:15] [main/INFO]: Reloading ResourceManager: Default, bukkit
    [16:30:16] [Worker-Main-5/INFO]: Loaded 7 recipes
    [16:30:17] [Server thread/INFO]: Starting minecraft server version 1.16.5
    [16:30:17] [Server thread/INFO]: Loading properties
    [16:30:17] [Server thread/INFO]: This server is running CraftBukkit version 3096-Spigot-9fb885e-296df56 (MC: 1.16.5) (Implementing API version 1.16.5-R0.1-SNAPSHOT)
    [16:30:18] [Server thread/INFO]: Debug logging is disabled
    [16:30:18] [Server thread/INFO]: Server Ping Player Sample Count: 12
    [16:30:18] [Server thread/INFO]: Using 4 threads for Netty based IO
    [16:30:18] [Server thread/INFO]: Default game type: SURVIVAL
    [16:30:18] [Server thread/INFO]: Generating keypair
    [16:30:18] [Server thread/INFO]: Starting Minecraft server on MyIp:25578
    [16:30:18] [Server thread/INFO]: Using default channel type
    [16:30:19] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
    [16:30:19] [Server thread/WARN]: The exception was: java.net.BindException: Cannot assign requested address: bind
    [16:30:19] [Server thread/WARN]: Perhaps a server is already running on that port?
    [16:30:19] [Server thread/INFO]: Stopping server
    [16:30:19] [Server thread/INFO]: Saving players
    [16:30:19] [Server thread/INFO]: Saving worlds
     
  2. btw i replaced my ip address so i dont get doxed
     
  3. im using windows 10. and i tried at least 100 different ports, rebooted my pc, and closed all java processes and tried again.
    when the ip in the .properties file was empty it worked too.
     
  4. If it works when you don't set an ip in the server.properties why bother setting it to an ip, unless you really require it to connect to a specific IP address.

    The below is taken from https://minecraft.fandom.com/wiki/Server.properties

     
    • Agree Agree x 1
  5. thank you for your help that fixed it.
     
  6. Strahan

    Benefactor

    Yea, every time I see a failed to bind to port thread it's full of people talking about how to diagnose multiple programs fighting over the port when a lot of times, it has nothing to do with what. The verbiage of the error is significant:
    Cannot assign requested address refers to the IP address, not the port. The error if the port is actually in conflict is "Address already in use".

    It doesn't help that the next line proffers a possibility that it should know is not the case, heh.