Spigot Fast Async WorldEdit alpha-development-builds

Blazingly fast world manipulation for builders, large networks and developers.

  1. How do I remove the compass teleporting?
  2. Nah, it doesnt sounds bad so no problem.
    Also how do i access the "command gui" that you added a few month ago ?

    just send a log error
    INFO Guigui5031 issued server command: //gui 22.04 22:24:08 [Server] ERROR An unexpected error occurred while handling a FAWE command 22.04 22:24:08 [Server] INFO java.lang.UnsupportedOperationException: Not implemented 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.command.UtilityCommands.gui(UtilityCommands.java:913) ~[FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_161] 22.04 22:24:08 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_161] 22.04 22:24:08 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_161] 22.04 22:24:08 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_161] 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.util.command.parametric.ParametricCallable.call(ParametricCallable.java:245) ~[FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.util.command.SimpleDispatcher.call(SimpleDispatcher.java:125) ~[FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.extension.platform.CommandManager.handleCommandOnCurrentThread(CommandManager.java:383) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.extension.platform.CommandManager$2$1.run(CommandManager.java:468) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.boydti.fawe.object.FawePlayer$2.run(FawePlayer.java:226) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.boydti.fawe.object.FawePlayer.queueAction(FawePlayer.java:254) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.boydti.fawe.object.FawePlayer.runAction(FawePlayer.java:301) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at com.sk89q.worldedit.extension.platform.CommandManager$2.run(CommandManager.java:465) [FastAsyncWorldEdit-bukkit-18.04.18-b4bb0dd-1074-19.5.8.jar:?] 22.04 22:24:08 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.schedule
  3. @Guigui5031
    The GUI is only for MCPE right now. Need to wait for the PC version to catch up (It should be either 1.13 or 1.14)

    Don't give them the perms:
    - worldedit.navigation.thru.tool
    - worldedit.navigation.jumpto.tool

    Or just change the item in the WorldEdit config.yml to something else
  4. Hello
    Restrict to specific terrain angle
    The -o flag will only overlayExample: /[0d][45d]
    Explanation: Allows any block where the adjacent block is between 0 and 45 degrees.
    Example: /[3][20]
    Explanation: Allows any block where the adjacent block is between 3 and 20 blocks below

    //replace /[0d][45d] 2
    //gmask /[0d][45d]
    //set ...

    it doesn't work :/
    Isn‘t the angle mask broken already for some weeks?
  5. hi, this it's a very nice plugin, congrat!!
    i have a problem.
    i need to know how to change the radius limit in brush commands, by default it said that only can make changes on 5 block radius
    so, i want to increse that limit!
  6. :( Help.. (This is when you try to load any schematic with empcraft.com :/ )

    Attached Files:

  7. andrewkm

    Patron ⭐⭐⭐

  8. Can't do nothing on VoxelSniper !
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: java.lang.NoSuchMethodError: com.boydti.fawe.util.WEManager.getMask(Lcom/boydti/fawe/object/FawePlayer;)[Lcom/boydti/fawe/object/RegionWrapper;
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.thevoxelbox.voxelsniper.Sniper.snipeOnCurrentThread(Sniper.java:171)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.thevoxelbox.voxelsniper.Sniper$1$1.run(Sniper.java:151)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.boydti.fawe.object.FawePlayer$2.run(FawePlayer.java:230)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.boydti.fawe.object.FawePlayer.queueAction(FawePlayer.java:258)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.boydti.fawe.object.FawePlayer.runAction(FawePlayer.java:305)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at com.thevoxelbox.voxelsniper.Sniper$1.run(Sniper.java:148)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:71)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    [00:28:09] [Craft Scheduler Thread - 14/WARN]: at java.lang.Thread.run(Thread.java:745)
  9. Someone Seriously help, ive been looking FOREVER and no one has this problem, i use twitch and im setting up a roleplay series, alone, and while using a new world edit, it outlines the blocks that i use. I can't get rid of it, it isnt the outline tool and im seriously just so annoyed. Someone help.
  10. IDK if the first one worked, but i need help. On my new world edit, it outlines all my blocks when i select it with the wooden axe. It wont go away and no where else explains. I know it isnt the outline tool. Someone help!
  11. JamesPixie
    I had same problem myself - my solution was -
    Goto - Options,,, - Controls... - Scroll down to WorldEditCUI - change Clear WorldEdit selection to BACKSLASH (key I chose) - very useful - (note I have Liteloader and WorldEditCui not vanillia MC)

    OR type
    see- http://wiki.sk89q.com/wiki/WorldEdit/Reference
  12. Omg thank you so much!
  13. After updating FAWE its broken an automatic script I have that runs to reset an area, a simple paste of a schematic from console.
    it now runs once and then it says "(FAWE) Please wait until your current action completes"
    and it just repeats that, its a tiny area that gets reset and It never used to do this.
    It started all of a sudden after I updated paperspigot/we/fawe

    its a very simple script I run every hour
    Code (Text):
        runas('~console','/clearclipboard ')
        runas('~console','/jumpto worldname_1,-382,63,-866')
        runas('~console','//schem load partofspawnregen')
        runas('~console','//paste -o')
        runas('~console','/clearclipboard ')
    if I run each line as a player it all works fine,
    but if i run them together it says that error.
  14. 24.05 09:25:44 [Server] WARN Plugin FastAsyncWorldEdit v18.05.24-099f733-1136-20.1.6 generated an exception while executing task 4
    24.05 09:25:44 [Server] INFO java.lang.IllegalStateException: zip file closed
    24.05 09:25:44 [Server] INFO at java.util.zip.ZipFile.ensureOpen(ZipFile.java:686) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.util.zip.ZipFile.getEntry(ZipFile.java:315) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.util.jar.JarFile.getEntry(JarFile.java:240) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.util.jar.JarFile.getJarEntry(JarFile.java:223) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:120) ~[patched_1.12.2.jar:git-Paper-1424] 24.05 09:25:44 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.getClassByName(JavaPluginLoader.java:189) ~[patched_1.12.2.jar:git-Paper-1424]
    24.05 09:25:44 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:115) ~[patched_1.12.2.jar:git-Paper-1424] 24.05 09:25:44 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:104) ~[patched_1.12.2.jar:git-Paper-1424]
    24.05 09:25:44 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.lang.Class.forName0(Native Method) ~[?:1.8.0_151] 24.05 09:25:44 [Server] INFO at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at com.boydti.fawe.bukkit.Metrics.isMineshafterPresent(Metrics.java:437) ~[?:?]
    24.05 09:25:44 [Server] INFO at com.boydti.fawe.bukkit.Metrics.postPlugin(Metrics.java:374) ~[?:?]
    24.05 09:25:44 [Server] INFO at com.boydti.fawe.bukkit.Metrics.access$100(Metrics.java:21) ~[?:?]
    24.05 09:25:44 [Server] INFO at com.boydti.fawe.bukkit.Metrics$1.run(Metrics.java:231) ~[?:?]
    24.05 09:25:44 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:63) ~[patched_1.12.2.jar:git-Paper-1424] 24.05 09:25:44 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52) [patched_1.12.2.jar:git-Paper-1424]
    24.05 09:25:44 [Server] INFO at com.destroystokyo.paper.ServerSchedulerReportingWrapper.run(ServerSchedulerReportingWrapper.java:22) [patched_1.12.2.jar:git-Paper-1424]
    24.05 09:25:44 [Server] INFO at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_151]
    24.05 09:25:44 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]
  15. Hi there. I have a quick question:

    I want to give donators access to use worldedit along with plotsquared so I've given them the fawe.permpack.basic permission as well as the fawe.plotsquared permission.

    It works perfectly, but because our server only uses multiple worlds, they can type //wand in any world and get a wooden axe. This messes up some inventories where they get items like a navigator and so on and I was just wondering if there was any way I could fix this without denying the command in the global region for each world? In my opinion it's just very unprofessional to do it this way.

    I know I can just deny the wand command in each world's global region, but as mentioned above it's unprofessional and I would like to know if there would be a way to only allow them to use worldedit commands in the plotsquared world instead of everywhere?
  16. @ShawnPR1
    Set the permissions per world instead of globally.
  17. I completely forgot about that. Thanks for your help man I appreciate it.

    Problem has been solved by simply adding the permissions per world.
  18. I'm running PlotSquared on a Creative server alongside a Freebuild world.
    I've set region restrictions to true as I want the plotsquared hook to work but this makes it so no users can use W/E in non-plot worlds. Is there anyway to fix this?