Spigot Fast Chunk Pregenerator 2.0.6

Generate chunks | Sync/Async | Pregen filter for high performance

  1. Just go to your spawn and call. Radius might be something like 5000 which will generate a 10k x 10k map to discover
    /fcp start <radius>


    Starts generation from current player position with a radius in blocks.
    /fcp start <radius>
     
  2. [16:53:07 INFO]: [FastChunkPregenerator] Disabling FastChunkPregenerator v2.0.6-SNAPSHOT
    [16:53:10 WARN]: Exception in thread "Skript offline player resolver thread (fetches UUIDs from the minecraft servers)" java.lang.NoClassDefFoundError: Could not initialize class ch.njol.skript.bukkitutil.UnresolvedOfflinePlayer
    [16:53:10 WARN]: at ch.njol.skript.bukkitutil.UnresolvedOfflinePlayer$1.run(UnresolvedOfflinePlayer.java:61)
    [16:53:10 WARN]: at java.base/java.lang.Thread.run(Thread.java:834)

    (Server is on a bungee)
     
  3. This is not an error of my plugin. Thats from some random skript.
     
  4. Hey, what is chunkx and chunkz? I'm not so smart on this stuff...
     
  5. Sorry, I didn't see the explanation...
     
  6. upload_2021-4-16_0-28-42.png
    It just says Fetching coordinates ALLLLLL day, not working anymore?
     
  7. Nope. Everything works fine for me. What Spigot and FCP version are you using?
    If nothing helps then just stop the server and remove all files but the configuration.yml from the plugin folder
    and make sure that you give FCP enough of your tick time with
    MaxMillisPerTick: something > ~15
     
  8. [FastChunkPregenerator] >> Async chunk loading support is enabled.
    03.05 22:04:36 [Server] ERROR Error occurred while enabling FastChunkPregenerator v2.0.6-SNAPSHOT (Is it up to date?)
    03.05 22:04:36 [Server] INFO java.lang.IllegalStateException: The world to be generated is not loaded.
     
  9. Delete the loading queue file. It tries to continue generating a world that seems not to be loaded anymore.
     
  10. Hey I am a small server developer and I had request for your plugin. My map is rectangular and it would be nice for there to be a command for rectangular maps. For now I will probably head over to chunky for a pregenerator, but I would use this because it has better performance and is an independent chunk pregenerator rather then being bunched up with other features like chunky's pregenerator.
     
  11. Error when i start the generation:
    ServerVersion: v1_8_R3
    Code (Text):
    [PS-1-8-1]java.lang.NoSuchMethodError: org.bukkit.World.isChunkGenerated(II)Z
    [PS-1-8-1]d >   at com.gestankbratwurst.fastchunkpregen.generation.tasks.ChunkGenerationFilter.proceed(ChunkGenerationFilter.java:99) ~[?:?]
    [PS-1-8-1]d >   at com.gestankbratwurst.fastchunkpregen.generation.tasks.GeneratorTask.run(GeneratorTask.java:158) ~[?:?]
    [PS-1-8-1]d >   at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:59) ~[PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:352) [PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:783) [PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:378) [PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:713) [PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:616) [PAPER_1_8_8.jar:git-PaperSpigot-"4c7641d"]
    [PS-1-8-1]d >   at java.lang.Thread.run(Thread.java:748) [?:1.8.0_282]
     
  12. Im sorry but my resource is written using the newest Spigot version. It might run on 1.13+ but def not on 1.8 because that version
    is half a decade old and i cant sacrifice half of the API while trying to support such old versions.
     
  13. Hey, I have a map installed on my server that I want to generate, but will this plugin generate the map correctly or will it just generate normal land?
     
  14. It uses whatever generator you are using. So the same as if a player was to run around and discover new chunks.
     
  15. Did 1.17 support roll out? @7smile7 I wanted to use your plugin, but started a task and it didn't even start fetching coordinates, so I assume it's not working on spigot 1.17.
    I am using chunky for now but I'd rather use your plugin, do I need papermc for it to work, or can you update it to support 1.17? Thanks!
     
  16. Didnt even see 1.17 was out XD
    Ill take a quick look at it.

    Edit:
    Just tested it on 1.17 and it works fine. No update needed ^^
     
    #196 7smile7, Jun 14, 2021
    Last edited: Jun 14, 2021
  17. Hey! It seems like this is an awesome plugin! However, does it run on 1.8.8 paper? But keep up the great work!
     
  18. Is there any way to get fcp to respect /wb (WorldBorder Plugin) boundaries? I've set the border but running fcp says the worldsize is unsupported. Running the vanilla /worldborder get command returns the default vanilla world border.
     
  19. I would recommend just setting the vanilla worldborder to the same size as the one from the plugin and then filling it up.
     
  20. Hayii, I wonder if I'm doing something wrong. I've set up a new server and decreased the size of the natural world border to 500. Then I ran the “fcp fillvanilla 8 world” command. After the process finished I reloaded the Dynmap of my server and noticed some black spots on the corners of the world and a chunk that should not be loaded in the top left corner. I tried to run the command a second time and after the process of filtering pre-generated chunks finished, it generated 63 additional chunks but nothing changed on the map. I tried to run the command a third time which results in the same output and no changes.

    unknown1-min.png

    Additionally, I tried to load the world in MCASelector-1.16.2 to check if it’s a Dynmap bug but it doesn’t seem to be a problem with Dynmap. In MCASelector the world looks even worse including more missing chunks all over the map and a bigger area in the top left corner.

    unknown-min.png

    Am I doing something wrong or is it normal?