Premium FeatherBoard [Paid]

Discussion in 'Resource Discussion' started by Maximvdw, Dec 28, 2014.

  1. [02:47:25 INFO]: [FeatherBoard] Enabling FeatherBoard v5.0.3b
    [02:47:25 INFO]: [FeatherBoard] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    [02:47:25 INFO]: [FeatherBoard] Plugin: FeatherBoard v5.0.3b
    [02:47:25 INFO]: [FeatherBoard] Framework version: 2021-07
    [02:47:25 INFO]: [FeatherBoard] Author: Maximvdw (Maxim Van de Wynckel)
    [02:47:25 INFO]: [FeatherBoard] Site: https://www.mvdw-software.com/
    [02:47:25 INFO]: [FeatherBoard] Copyright: 2013-2021 All Rights Received
    [02:47:25 INFO]: [FeatherBoard] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    [02:47:25 INFO]: You are using a BETA plugin. Keep in mind this build might
    [02:47:25 INFO]: contain bugs and the configuration is most likely to get
    [02:47:25 INFO]: a reset when new features are added.
    [02:47:25 INFO]: [FeatherBoard] Loading configuration ...
    [02:47:25 INFO]: [FeatherBoard] Loading messages ...
    [02:47:25 INFO]: [FeatherBoard] Loading language file: lang_en
    [02:47:25 INFO]: [FeatherBoard] Checking for module updates ...
    [02:47:25 INFO]: [FeatherBoard] Fetching modules from server ...
    [02:47:25 INFO]: [FeatherBoard] Loading custom effect 'example3' ...
    [02:47:25 INFO]: [FeatherBoard] Creating new custom effect: example3
    [02:47:25 ERROR]: Error occurred while enabling FeatherBoard v5.0.3b (Is it up to date?)
    java.lang.ExceptionInInitializerError: null
    at org.openjdk.nashorn.internal.runtime.Context.compile(Context.java:1509) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context.compileScript(Context.java:1449) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context.compileScript(Context.java:759) ~[?:?]
    at org.openjdk.nashorn.api.scripting.NashornScriptEngine.compileImpl(NashornScriptEngine.java:528) ~[?:?]
    at org.openjdk.nashorn.api.scripting.NashornScriptEngine.compileImpl(NashornScriptEngine.java:517) ~[?:?]
    at org.openjdk.nashorn.api.scripting.NashornScriptEngine.evalImpl(NashornScriptEngine.java:395) ~[?:?]
    at org.openjdk.nashorn.api.scripting.NashornScriptEngine.eval(NashornScriptEngine.java:151) ~[?:?]
    at be.maximvdw.featherboard.UM.J(UM.java:77) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.UM.<init>(UM.java:43) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.z.u(z.java:70) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.z.R(z.java:20) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.FeatherBoard.J(FeatherBoard.java:81) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.t.W(t.java:46) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.t.onEnable(t.java:14) ~[FeatherBoard.jar:?]
    at be.maximvdw.featherboard.FeatherBoard.onEnable(FeatherBoard.java:30) ~[FeatherBoard.jar:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.17.1.jar:git-Airplane-87]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[patched_1.17.1.jar:git-Airplane-87]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:500) ~[patched_1.17.1.jar:git-Airplane-87]
    at org.bukkit.craftbukkit.v1_17_R1.CraftServer.enablePlugin(CraftServer.java:535) ~[patched_1.17.1.jar:git-Airplane-87]
    at org.bukkit.craftbukkit.v1_17_R1.CraftServer.enablePlugins(CraftServer.java:449) ~[patched_1.17.1.jar:git-Airplane-87]
    at net.minecraft.server.MinecraftServer.loadWorld(MinecraftServer.java:725) ~[patched_1.17.1.jar:git-Airplane-87]
    at net.minecraft.server.dedicated.DedicatedServer.init(DedicatedServer.java:308) ~[patched_1.17.1.jar:git-Airplane-87]
    at net.minecraft.server.MinecraftServer.x(MinecraftServer.java:1212) ~[patched_1.17.1.jar:git-Airplane-87]
    at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:319) ~[patched_1.17.1.jar:git-Airplane-87]
    at java.lang.Thread.run(Thread.java:833) [?:?]
    Caused by: java.lang.RuntimeException: java.lang.NoSuchMethodException: no such method: sun.misc.Unsafe.defineAnonymousClass(Class,byte[],Object[])Class/invokeVirtual
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.lambda$getDefineAnonymousClass$0(Context.java:335) ~[?:?]
    at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.getDefineAnonymousClass(Context.java:327) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.<clinit>(Context.java:317) ~[?:?]
    ... 25 more
    Caused by: java.lang.NoSuchMethodException: no such method: sun.misc.Unsafe.defineAnonymousClass(Class,byte[],Object[])Class/invokeVirtual
    at java.lang.invoke.MemberName.makeAccessException(MemberName.java:976) ~[?:?]
    at java.lang.invoke.MemberName$Factory.resolveOrFail(MemberName.java:1117) ~[?:?]
    at java.lang.invoke.MethodHandles$Lookup.resolveOrFail(MethodHandles.java:3649) ~[?:?]
    at java.lang.invoke.MethodHandles$Lookup.findVirtual(MethodHandles.java:2680) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.lambda$getDefineAnonymousClass$0(Context.java:329) ~[?:?]
    at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.getDefineAnonymousClass(Context.java:327) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.<clinit>(Context.java:317) ~[?:?]
    ... 25 more
    Caused by: java.lang.NoSuchMethodError: 'java.lang.Class sun.misc.Unsafe.defineAnonymousClass(java.lang.Class, byte[], java.lang.Object[])'
    at java.lang.invoke.MethodHandleNatives.resolve(Native Method) ~[?:?]
    at java.lang.invoke.MemberName$Factory.resolve(MemberName.java:1085) ~[?:?]
    at java.lang.invoke.MemberName$Factory.resolveOrFail(MemberName.java:1114) ~[?:?]
    at java.lang.invoke.MethodHandles$Lookup.resolveOrFail(MethodHandles.java:3649) ~[?:?]
    at java.lang.invoke.MethodHandles$Lookup.findVirtual(MethodHandles.java:2680) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.lambda$getDefineAnonymousClass$0(Context.java:329) ~[?:?]
    at java.security.AccessController.doPrivileged(AccessController.java:318) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.getDefineAnonymousClass(Context.java:327) ~[?:?]
    at org.openjdk.nashorn.internal.runtime.Context$AnonymousContextCodeInstaller.<clinit>(Context.java:317) ~[?:?]
    ... 25 more
    [02:47:25 INFO]: [FeatherBoard] Disabling FeatherBoard v5.0.3b
    [02:47:25 INFO]: [FeatherBoard] Cancelling all tasks ...
     
  2. Hello. I purchased this plugin many months ago and now that im back to developing my server, I went to download it once again but found that I no longer own the plugin. Is this some sort of mistake or do I loose ownership of downloading it after a certain amount of time?
     
  3. Hi, i tried to add some additional money placeholder formats but I can't these to show on the scoreboard, what am i doing wrong?

    # Formatted money settings
    money_formatted:
    fix_thousands: true
    fix_millions: true
    thousands_format: "K"
    millions_format: "M"
    billions_format: "B"
    trillions_format: "T"
    quadrillions_format: "Q"
    quintillions_format: "QT"
    sextillions_format: "S"
    septillions_format: "ST"
    octillions_format: "O"
    decillions_format: "N"
    undecillions_format: "UD"
     
  4. Can you please add support for Java 16?
     
  5. Still no updates, crazy stuff...

    I have no choice but to look somewhere else, I guess.

    Was good while it lasted.
     
  6. Maximvdw

    Benefactor

    java 16 support was added in June.. please read the update log
     
  7. Maximvdw

    Benefactor

    this is an issue in PAPI (or the placeholder of papi that hooks in Season)
     
  8. Maximvdw

    Benefactor

    it looks like you have no internet to download the dependencies from maven central?
     
  9. Maximvdw

    Benefactor

    all placeholders are working - please note that all placeholders are now handled in PAPI (so no {}, but %%) the documentation page was updated in June to redirect to the papi page for a list of all placeholders. MVdWPlaceholderAPI handled event triggers, but due to many requests we removed its requirement and switched to papi. Event triggers are still possible through the API (and many plugins use the Featherboard api to toggle a scoreboard). Switching scoreboards is not removed - the commands /fb show xxx still provide this. The GUI command was hardly used according to statistics and often the raw command was used or a different GUI plugin was used to trigger the show command.
     
  10. Maximvdw

    Benefactor

    update to java 15 or higher
     
  11. Maximvdw

    Benefactor

    Ownership does not disappear unless a chargeback was performed (in which spigot removes it automatically). Make sure you do not have duplicate spigot accounts and logged in with a different account.
     
  12. Maximvdw

    Benefactor

    Maximvdw updated FeatherBoard with a new update entry:

    v5.0.4 - Bugfixes, Warnings and Error Handling

    Read the rest of this update entry...
     
  13. Just tested this bug using the latest release of FB, and it still seems to be the case. Any chance you could fix it?
     
  14. Maximvdw

    Benefactor

    Static lines will never refresh (seeing no frames or placeholders means nothing can update it). Can you give the complete scoreboard config?
     
  15. That makes sense, but I didn't have the issue in version 4 which is weird.

    Here is my config: https://pastebin.com/pBd5vZN1
    Here is my default scoreboard: https://pastebin.com/UuPHyRtv
     
  16. The new update dont work


    openjdk version "1.8.0_282"
    OpenJDK Runtime Environment (build 1.8.0_282-b08)
    OpenJDK 64-Bit Server VM (build 25.282-b08, mixed mode)
    :/home/container$ java -Xms2G -Xmx2G -XX:+UseG1GC -XX:+ParallelRefProcEnabled -XX:MaxGCPauseMillis=200 -XX:+UnlockExperimentalVMOptions -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -XX:G1NewSizePercent=30 -XX:G1MaxNewSizePercent=40 -XX:G1HeapRegionSize=8M -XX:G1ReservePercent=20 -XX:G1HeapWastePercent=5 -XX:G1MixedGCCountTarget=4 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=90 -XX:G1RSetUpdatingPauseTimePercent=5 -XX:SurvivorRatio=32 -XX:+PerfDisableSharedMem -XX:MaxTenuringThreshold=1 -Dusing.aikars.flags=https://mcflags.emc.gs -Daikars.new.flags=true -Dpaper.playerconnection.keepalive=60 -Duser.timezone=Europe/Paris -jar server.jar nogui
    Loading libraries, please wait...
    [13:43:08 INFO]: Starting minecraft server version 1.8.8
    [13:43:08 INFO]: Loading properties
    [13:43:08 INFO]: Default game type: SURVIVAL
    [13:43:08 INFO]: This server is running CraftBukkit version git-PaperSpigot-"4c7641d" (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [13:43:08 INFO]: Debug logging is disabled
    [13:43:08 INFO]: Spigot Timings: true - Verbose: true - Interval: 5m - Length: 60m
    [13:43:08 INFO]: Server Ping Player Sample Count: 12
    [13:43:08 INFO]: Using 4 threads for Netty based IO
    [13:43:08 INFO]: Data value allowed items:
    [13:43:08 INFO]: Generating keypair
    [13:43:08 INFO]: Starting Minecraft server on 0.0.0.0:25571
    [13:43:08 INFO]: Using epoll channel type
    [13:43:08 INFO]: Set PluginClassLoader as parallel capable
    [13:43:08 ERROR]: Could not load 'plugins/FeatherBoard.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: be/maximvdw/featherboard/FeatherBoard has been compiled by a more recent version of the Java Runtime (class file version 59.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:331) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:254) [patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:293) [patched.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:202) [patched.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:563) [patched.jar:git-PaperSpigot-"4c7641d"]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_282]
    Caused by: java.lang.UnsupportedClassVersionError: be/maximvdw/featherboard/FeatherBoard has been compiled by a more recent version of the Java Runtime (class file version 59.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_282]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_282]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_282]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:468) ~[?:1.8.0_282]
    at java.net.URLClassLoader.access$100(URLClassLoader.java:74) ~[?:1.8.0_282]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:369) ~[?:1.8.0_282]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:363) ~[?:1.8.0_282]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_282]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:362) ~[?:1.8.0_282]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:102) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:87) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_282]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_282]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_282]
    at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_282]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    ... 6 more
     
  17. Hi,

    I just tried to add v5.04 of feather board, but it kept causing superiorskyblock2's nashorn-engine to not work properly.

    https://pastebin.com/TA8NYHmj


    I just added v4.30 and everything loaded properly so there must be something in the changes in featherboard causing this.
     
  18. Maximvdw

    Benefactor

    As mentioned in the main description page -you need at least java 11
     
  19. java 11 works with paper 1.8.8?
     
  20. openjdk version "11.0.10" 2021-01-19
    OpenJDK Runtime Environment 18.9 (build 11.0.10+9)
    OpenJDK 64-Bit Server VM 18.9 (build 11.0.10+9, mixed mode, sharing)
    :/home/container$ java -Xms2G -Xmx2G -XX:+UseG1GC -XX:+ParallelRefProcEnabled -XX:MaxGCPauseMillis=200 -XX:+UnlockExperimentalVMOptions -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -XX:G1NewSizePercent=30 -XX:G1MaxNewSizePercent=40 -XX:G1HeapRegionSize=8M -XX:G1ReservePercent=20 -XX:G1HeapWastePercent=5 -XX:G1MixedGCCountTarget=4 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=90 -XX:G1RSetUpdatingPauseTimePercent=5 -XX:SurvivorRatio=32 -XX:+PerfDisableSharedMem -XX:MaxTenuringThreshold=1 -Dusing.aikars.flags=https://mcflags.emc.gs -Daikars.new.flags=true -Dpaper.playerconnection.keepalive=60 -Duser.timezone=Europe/Paris -jar server.jar nogui
    Loading libraries, please wait...
    [12:58:30 INFO]: Starting minecraft server version 1.8.8
    [12:58:30 INFO]: Loading properties
    [12:58:30 INFO]: Default game type: SURVIVAL
    [12:58:30 INFO]: This server is running CraftBukkit version git-PaperSpigot-"4c7641d" (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [12:58:30 INFO]: Debug logging is disabled
    [12:58:30 INFO]: Spigot Timings: true - Verbose: true - Interval: 5m - Length: 60m
    [12:58:30 INFO]: Server Ping Player Sample Count: 12
    [12:58:30 INFO]: Using 4 threads for Netty based IO
    [12:58:30 INFO]: Data value allowed items:
    >WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.github.paperspigot.PaperSpigotConfig (file:/home/container/cache/patched.jar) to field java.lang.reflect.Field.modifiers
    WARNING: Please consider reporting this to the maintainers of org.github.paperspigot.PaperSpigotConfig
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    [12:58:30 INFO]: Generating keypair
    [12:58:30 INFO]: Starting Minecraft server on 0.0.0.0:25571
    [12:58:30 INFO]: Your platform does not provide complete low-level API for accessing direct buffers reliably. Unless explicitly requested, heap buffer will always be preferred to avoid potential system unstability.
    [12:58:30 INFO]: Using epoll channel type
    [12:58:30 INFO]: Set PluginClassLoader as parallel capable
    [12:58:30 ERROR]: Could not load 'plugins/FeatherBoard.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: be/maximvdw/featherboard/FeatherBoard has been compiled by a more recent version of the Java Runtime (class file version 59.0), this version of the Java Runtime only recognizes class file versions up to 55.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:331) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:254) [patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:293) [patched.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:202) [patched.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:563) [patched.jar:git-PaperSpigot-"4c7641d"]
    at java.base/java.lang.Thread.run(Thread.java:834) [?:?]
    Caused by: java.lang.UnsupportedClassVersionError: be/maximvdw/featherboard/FeatherBoard has been compiled by a more recent version of the Java Runtime (class file version 59.0), this version of the Java Runtime only recognizes class file versions up to 55.0
    at java.base/java.lang.ClassLoader.defineClass1(Native Method) ~[?:?]
    at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1017) ~[?:?]
    at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174) ~[?:?]
    at java.base/java.net.URLClassLoader.defineClass(URLClassLoader.java:550) ~[?:?]
    at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:458) ~[?:?]
    at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:452) ~[?:?]
    at java.base/java.security.AccessController.doPrivileged(Native Method) ~[?:?]
    at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:451) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:102) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:87) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589) ~[?:?]
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522) ~[?:?]
    at java.base/java.lang.Class.forName0(Native Method) ~[?:?]
    at java.base/java.lang.Class.forName(Class.java:398) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[patched.jar:git-PaperSpigot-"4c7641d"]
    ... 6 more