Firewall Help

Discussion in 'Spigot Discussion' started by PatrickMayo, May 3, 2013.

  1. Hi I've been trying to set up bungee across multiple servers.
    Yet i seem to be having problems with accessing a seconded Linux server with a Minecraft server on

    Every time i try to join that server from my Main hub server I get
    Could not connect to selected server, please try again later:
    java.net.NoRouteToHostException

    Ive tried setting up IPtables but get the same problem
    (Config setup of IP Table
    -A INPUT ! -s 1.2.3.4 -p tcp -m tcp --dport 25565 -j DROP​
    -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT​
    -A INPUT -p icmp -j ACCEPT​
    -A INPUT -i lo -j ACCEPT​
    -A INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT​
    -A INPUT -j REJECT --reject-with icmp-host-prohibited​
    -A FORWARD -j REJECT --reject-with icmp-host-prohibited​
    COMMIT​
    Obviously i changed the IP Address
    No matter what I tried I can't seem to get Bungee to connect to this server

    I tried setting it up with my personal home computer running windows and it worked fine
    Also if i just open the port without the IP whitelist it works fine
    Someone said on another post about using a IPwhitelisting plugin but I'd Rather learn what I'm doing wrong
    Heres my Bungee Config
    http://pastebin.com/DkqDuyyu

    Thanks In advance Pat
     
  2. You're dropping port 25565...
     
    • Winner Winner x 1
  3. so i just change it to
    -A INPUT ! -s 1.2.3.4 -p tcp -m tcp --dport 25565 -j ACCEPT
    ?
    Sorry I'm new to Linux
     
  4. Flush your iptables.

    You only want to deny access to the backend servers.
    So for example your servers are on ports 5000,5001 and 5002. You would do.
    iptables -I INPUT ! --src (ip) -m tcp -p tcp --dport 5000 -j DROP
    iptables -I INPUT ! --src (ip) -m tcp -p tcp --dport 5001 -j DROP
    iptables -I INPUT ! --src (ip) -m tcp -p tcp --dport 5002 -j DROP

    Then players would just connect through Bungee, and not be able to connect through the offline mode ports.

    [EDIT] Also make sure your creative server isnt on port 25565. Put it to 25567 or something