Spigot FireworkPerk [English&Spanish] 1.8.x 4.0

Random Firework on command for vips and ops

  1. TheMegaRock_ submitted a new resource:

    RandomFirework - Random Firework on command

    Read more about this resource...
     
  2. [14:56:13 WARN]: org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/TheMegaRock/MainFirework : Unsupported major.minor version 52.0
    u just compiled for Java 8.. a rellly not so good idea..most servers use Java 7 see here:
    http://mcstats.org/global/
    please recompile it for Java 7 / 8 (Java 8 can run java 7 plugins) or write in the descriptions: dependency: java 8
     
  3. Hi

    seems cool but got an error when i start my server 1.8.7

    Couldnot load FireworkPerk.jar
     
  4. spigot 1649 plugins are going ?
     
  5. i dont know all my other plugins are working well, thats very sad i wanted to give your plugin to my VIPs
     
  6. Sorry my english is very bad and
    I do not express myself
     
  7. the plugin is now 1.8.x for you ;D
     
  8. Thanks alots I try this in the afternoon :]

    did you upload a new version?

    Gracias
     
  9. yes, new version, hablas español? xD
     
  10. un poco, estoy estudiando al la universidad xD
     
  11. xD yo me estoy matando hablando ingles xD
     
  12. it does not work :(
     
  13. Server thread/ERROR]: Could not load 'plugins/FireworkPerk.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/TheMegaRock/MainFirework : Unsupported major.minor version 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:291) [spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_75]
    Caused by: java.lang.UnsupportedClassVersionError: me/TheMegaRock/MainFirework : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_75]
    at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[?:1.7.0_75]
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_75]
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_75]
    at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_75]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_75]
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_75]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_75]
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_75]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_75]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_75]
    at java.lang.Class.forName0(Native Method) ~[?:1.7.0_75]
    at java.lang.Class.forName(Class.java:274) ~[?:1.7.0_75]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-3ccbe77-a6a57a9]
    ... 6 more