Solved Forced Hosts - Not Working?

Discussion in 'BungeeCord Help' started by Avenged_, Sep 3, 2016.

  1. So, I've been trying to set up direct connect for my server, and I use BungeeCord. I wanted to have direct connect so if I had subdomains I could connect to a different server, and bypass going to the main hub.

    Ex.
    pvp.yourip.com - This would bring you directly to the PvP server.

    What I've tried:
    I've googled this issue plently of times, most posts just lead nowhere, or don't solve the problem when I try what they say. I've created an SRV record, and a A record for the subdomain. Also in the BungeeCord config I have the forced hosts section like this:

    Code (Text):
      forced_hosts:
        ctf.yourip.com: CTF
    Along with a server named CTF in the Bungee config.

    The Issue:
    The subdomain seems to work, I'm able to connect to my server, although it doesn't redirect me to the ctf server, it just brings me to the hub. This tells me that my A record & SRV record are fine and working. Did I miss something?

    If you've had this issue before and know the answer please help me out, thanks!
     
  2. If you are trying to use forced_hosts with an SRV Record, it's not going to work. You are going to have to make another listener with a different port, then direct that SRV Record to the port.
     
  3. Thanks for the help, I'll give this a shot!
     
  4. No problem, let me know if something else is wrong
     
  5. Thanks, I still couldn't get it to work, but I just did a small work around by coding a custom plugin to send the player to the server once they join. Thanks anyway, the subdomain technically works now :p