Spigot (FREE) Crate Reloaded - Mystery Crate [1.8 - 1.18.X] 2.0.26

Prime - HQ - Powerful - Active - Custom - Particles - Effects

  1. I love your plugins. They are so good and well-made. Good job on making them. Fantastic work on this plugin :) :) :) :) :) :) :) :) :) :) :) :)
     
  2. getting this error

    Code (Text):
    25.01 01:40:29 [Server] WARN @EventHandler method crate.bd#d returns non-void type boolean. This is unsupported behavior and will no longer work in a future version of Paper. This should be reported to the developers of CrateReloaded v2.0.25 (dinosaur)

    25.01 01:40:29 [Server] WARN @EventHandler method crate.bd#c returns non-void type boolean. This is unsupported behavior and will no longer work in a future version of Paper. This should be reported to the developers of CrateReloaded v2.0.25 (dinosaur)
    running purpur 1.18.1
     
    • Informative Informative x 1
  3. Hi i have found a bug, some players can steal display items from the open confirmation menu and possibly from the Roulete and other animations, i'm running the lastest version
     
  4. Please update to 1.18.2 - thank you
     
    • Agree Agree x 5
  5. Hi, I am noticing a weird behavior after upgrading from Spigot 1.18.1 to 1.18.2 where when I now run the command:
    , the item I receive does not have the name, lore nor glow effect.

    Below is just the top portion of the crate.yml configuration:
    The item just appears to be a normal tripwire hook, though when I click on anything, I get the "you may not use ..." message and I can not open the crate.

    No errors in console logs aside from "[Server] Server thread/INFO [CrateReloaded] Failed to initialize holograms: None is not enabled.", however I haven't ever used the holograms and this was working on previous versions of without it, and this seems totally unrelated.

    Any help with this would be greatly appreciated, thank you kindly
     
    • Agree Agree x 3
  6. What build are you using (Spigot/Paper/Vanilla, etc. and version?
    I am unable to duplicate on my end. Possible players that are able to pull the items are using a MC mod that applies changes to the chest / inventory GUI.
     
  7. im using lastest Crate Reloaded and git-Paper-794 (MC: 1.16.5) (Implementing API version 1.16.5-R0.1-SNAPSHOT), i remember when i used LootCrate, i reported a similar issue and them fixed, i'm using my crates without confirmation gui and animations for now, dtlTraders made a temp fix for this, making the inventory "read only" to dont accept changes you know?, even with the user pick an item from the GUI, when him exit the inventory rollback i think
     
  8. All keys can open the same crate since 1.18.2, rendering all other crates useless
     
  9. Hiya!
    I have a problem with obtaining a crate key that has been customised. Currently when I receive a crate key from commands, I obtain a normal item with no custom name or no enchantment glow. In this instance, I'm receiving a normal tripwire hook instead of a custom one. This means that players can use a normal tripwire hook to open a crate. I'm running a paper/spigot server on 1.18.2. This is the crate.yml file I have: https://pastebin.com/jTd1sthp

    Any help would be highly appreciated! Thank you!
     
    • Agree Agree x 1
  10. The developer has made a fix as of last Saturday for the Pro version, it appears the main issue is with NBT which was removed in the latest build for Pro version, but seems no update is available anywhere for the free edition. The pro version was prioritized which totally makes sense, hopefully the fixes will be applied to the free addition soon.

    The 1.18.2 update blew up numerous popular plugins, so it is what it is. I'm use they tried to keep NBT functionality as it is really nice to have, but I can live without it..
     
    • Useful Useful x 1
  11. why does the items i set as keys have no effects enchantment item name nothing custom when i use the default values you have set in the file .....??? running into a brickwall spent 2 days now trying to work around this any help would be appreciated ** PS if your free version doesn't work correctly your not setting good grounds for ANYONE to buy your PAID version i want to buy it but idk if thats broken too
     
    #1651 weston343, Mar 13, 2022
    Last edited: Mar 13, 2022
  12. is there support for 1.18.2 as well as a gui? i have used other plugins that dont use a gui to set it up and it is HELL. if so, how do i access it?
     
  13. Ive done /crates and it just says unknow command andd to ddo /help, I went into my logs and it said "is it up to date?"
    it is but Im worried I dont have a dependency but I cant find a list of them.
     
  14. Good plugin, used it for years. Only thing is that im not getting particles to work. May be because my server still runs 1.8.8. Anyone know if this can be fixed on my 1.8.8 server? Would be nice to see it work!
     
  15. TB1

    TB1

    I am running a 1.18.2 bukkit server on my computer and the crate reloaded plugin doesn't seem to be working, every time I type in a command it doesn't appear in chat or do anything does anyone know what the problem is.

    I got few messages on my console regarding crates:

    [01:12:39] [Server thread/WARN]: Legacy plugin CrateReloaded v1.3.26 does not specify an api-version.

    [01:12:42] [Server thread/INFO]: [CrateReloaded] Loading CrateReloaded v1.3.26

    [01:13:07] [Server thread/INFO]: [CrateReloaded] Enabling CrateReloaded v1.3.26

    [01:13:07] [Server thread/INFO]: [CrateReloaded] org.bukkit.craftbukkit.v1_18_R2

    [01:13:07] [Server thread/ERROR]: Error occurred while enabling CrateReloaded v1.3.26 (Is it up to date?)

    java.lang.NoSuchMethodError: 'org.bukkit.configuration.file.YamlConfiguration org.bukkit.configuration.file.YamlConfiguration.loadConfiguration(java.io.InputStream)'

    at cratereloaded.B.reloadConfig(Config.java:31) ~[?:?]

    at cratereloaded.B.getConfig(Config.java:44) ~[?:?]

    at cratereloaded.b.f(CrateReloaded.java:200) ~[?:?]

    at cratereloaded.b.e(CrateReloaded.java:189) ~[?:?]

    at cratereloaded.b.onEnable(CrateReloaded.java:60) ~[?:?]

    [01:14:55] [Server thread/INFO]: [CrateReloaded] Disabling CrateReloaded v1.3.26

    [01:14:55] [Server thread/ERROR]: Error occurred while disabling CrateReloaded v1.3.26 (Is it up to date?)

    java.lang.NullPointerException: Cannot invoke "cratereloaded.aM.disable()" because "this.d" is null

    at cratereloaded.b.cleanup(CrateReloaded.java:90) ~[?:?]


    at cratereloaded.b.onDisable(CrateReloaded.java:78) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:266) ~[bukkit-1.18.2-R0.1-SNAPSHOT.jar:?]

    [01:14:57] [Server thread/WARN]: Legacy plugin CrateReloaded v1.3.26 does not specify an api-version.

    [01:14:58] [Server thread/INFO]: [CrateReloaded] Loading CrateReloaded v1.3.26

    [01:15:11] [Server thread/INFO]: [CrateReloaded] Enabling CrateReloaded v1.3.26

    [01:15:11] [Server thread/INFO]: [CrateReloaded] org.bukkit.craftbukkit.v1_18_R2

    [01:15:11] [Server thread/ERROR]: Error occurred while enabling CrateReloaded v1.3.26 (Is it up to date?)

    java.lang.NoSuchMethodError: 'org.bukkit.configuration.file.YamlConfiguration org.bukkit.configuration.file.YamlConfiguration.loadConfiguration(java.io.InputStream)'

    at cratereloaded.B.reloadConfig(Config.java:31) ~[?:?]

    at cratereloaded.B.getConfig(Config.java:44) ~[?:?]

    at cratereloaded.b.f(CrateReloaded.java:200) ~[?:?]

    at cratereloaded.b.e(CrateReloaded.java:189) ~[?:?]

    at cratereloaded.b.onEnable(CrateReloaded.java:60) ~[?:?]

    ...

    I don't understand what any of this means if someone does I would really appreciate it if you could help me out (I downloaded the plugin from bukkit because the spigot one didn't load the files when I started the server)