Friends Can't Join My Server

Discussion in 'Spigot Help' started by Grindser, May 27, 2018.

  1. I would start by fixing the countless startup errors caused by plugins.
     
    • Winner Winner x 1
  2. Im pretty sure the server is in offline mode, Change it to online, see if that works
     
  3. The Server is in online mode, ill fix the plugin errors now.
     
  4. Code (Text):
    [10:52:00] [User Authenticator #3/INFO]: UUID of player Grindser is 920f02a9-96b0-43c5-bf0f-4924dfaa364d
    [10:52:00] [Server thread/INFO]: Grindser[/127.0.0.1:59947] logged in with entity id 351 at ([Hub] -11.918176541530853, 26.0, 66.69041676846508)
    [10:52:18] [Server thread/INFO]: Grindser lost connection: Disconnected
    [10:52:18] [Server thread/WARN]: java.lang.IllegalArgumentException: No suitable constructor could be found.
    [10:52:18] [Server thread/WARN]:    at com.comphenix.protocol.injector.PacketConstructor.withPacket(PacketConstructor.java:179)
    [10:52:18] [Server thread/WARN]:    at com.comphenix.protocol.injector.PacketFilterManager.createPacketConstructor(PacketFilterManager.java:902)
    Thats the error I see, I think that you are receiving to many packets due to the entity you are disguised as, thus disconnecting you, Try uninstalling the disguising plugin
     
  5. Also, If you have bungeecord, Can I see that config aswell as the bukkit.yml config
     
  6. I have fixed the disguise plugin but my friend can still not join.
     
  7. Are you using the Latest ProtocolLib?
     
  8. I don't think so, i'll check later.
     
  9. Aight so, im gonna start over with a bungeecord instead.
     
  10. You need to have the latest version of ProtocolLib, it's causing login issues I see.