1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug GAListener Not Working

Discussion in 'Bugs & Feature Requests' started by BlizzardMC_, Jul 18, 2015.

  1. @BlizzardMC_ PM me I will send you a custom plugin for free :p
     
  2. RainbowDev, it still dont work the one u sent me
     
  3. Nvm, Rainbow its working now.
     
  4. ERROR:

    while parsing a block mapping
    in "<unicode string>", line 32, column 1:
    settings:
    ^
    expected <block end>, but found '<block mapping start>'
    in "<unicode string>", line 151, column 3:
    '75':
    ^
     
  5. But it is not giving the player the rewards, help please?
     
  6. Update: /vote is working now, but it does not give them the rewards,
     
  7. pastebin your config
     
  8. You for got quotes around the commands, if one quote is missing gal wont work and it wont show any errors.

    1. luckyvotes:
    2. '10':
    3. broadcast: '{GREEN}{username} {GOLD}was lucky an extra {GREEN}$5,000 + 500 EXP!'
    4. playermessage: '{GOLD}You were lucky and received an extra {GREEN}$5,000 + 500 EXP!'
    5. commands:
    6. - /eco give {username} 5000 --------these 2 lines need quotes
    7. - /xp give {username} 500
    8. '20':
    9. broadcast: '{GREEN}{username} {GOLD}was lucky and received {GREEN}$10,000 + 1500 EXP!'
    10. playermessage: '{GOLD}You were lucky and received {GREEN}$10,000 + 1500 EXP!'
    11. commands:
    12. - '/eco give {username} 10000'
    13. - '/xp give {username} 1500'
    14. '50':
     
  9. mk, is wat u just sent the correct one?
     
  10. no look under commands...
    they need quotes
    1. - /eco give {username} 5000 --------these 2 lines need quotes
    2. - /xp give {username} 500
    make em look like
    1. '- /eco give {username} 5000'
    2. '- /xp give {username} 500'