Gameseer, a new Administration Panel

Discussion in 'Server & Community Management' started by SirSavary, Nov 20, 2013.

  1. I think everyone gets to test it and then licenses are being added later.
     
    • Useful Useful x 1
  2. Update
    IT WORKS! The stuff I implemented works perfectly and there won't be any future code headaches! :D

    Eating dinner and then I will be working on running it through Grunt and uploading the build!
     
    • Like Like x 2
    • Informative Informative x 1
  3. Yee haw!

    Very excited to have this up and running!
     
  4. So if I am to donate now, do I get the current build?
     
  5. Current and all future.

    Update
    I've spent the last few hours trying to fix what should be the last bug before I can push this thing. I'm getting an error only on the compiled Javascript version, not the Coffeescript version. This makes little sense to me as the Coffeescript is compiled to Javascript in real-time when I'm developing.

    Screenie of the error in question: http://gyazo.com/3ece70fd7498cfda4c3c73be871ebfc5

    It's simple error really, just need to throw some logging in there and find out why it isn't working correctly. In the meantime I'm going to bed to avoid burnout, will resume work as soon as I can tomorrow. Hopefully this will be the last of what feels like an endless series of hurdles :/
     
  6. DAAAMNNIIITTTTT!!! I'm loosing hope after reading every post of yours :(
     
  7. But theres still that bit of hope left...waiting...
     
  8. It's still happening, this is just a tricky process. I'm taking one language and turning it into another. 95% of the time it works as expected, but sometimes there are small issues that occur during the compilation process. I could distributed the CoffeeScript source files, BUT, Gameseer would not run nearly as fast and it would be much larger. On top of this, I'd be freely handing out the sourcecode. I do not want to do this. If you want to see a functioning build, look back a few pages. @Dominic Martin posted a link to a mirror of version 0.2.
     
  9. How do we use that? o_O
    I tried to upload it on my server buttt, can't figure out how to use it :p
    It's just showing me the .js files :/
     
  10. ooo, thanks for a link to a old version! Faith restored!!!!
     
  11. To use the old version you need to install NodeJS. You can download it from http://nodejs.org/download/. Once it's installed, use your computer's terminal / commandline to go into the directory where you download (and unzipped) Gameseer. Run the following commands once you're in there:
    1. npm install
    2. node Main.js
    Read the console output to make sure everything is good to go and you should be able to access Gameseer by going to http://localhost in your browser. I would give more detailed support but I'm currently working on getting version 0.3 ready as it uses a much, much different codebase and there are few similarities.
     
  12. Can we get some pictures of what the Gameseer panel will look like now, I don't think we have had an update for 20 pages :p
     
    • Agree Agree x 1
  13. Teg

    Teg
    Supporter

    I installed this and then ran it, I was unable to actually access the panel, and after about 10 minutes of it being open it stopped responding http://i.imgur.com/vycLC5C.png
     
  14. didn't even load for me.
    but don't forget, that was one of the unstable builds :)
     
  15. try http://localhost:1080

    Update
    Ended up having to take care of something irl yesterday and didn't get to add the debug code to fix the build issue. Working on that now.
     
  16. Teg

    Teg
    Supporter

    Trying to connect on port 1080 still didn't work. (btw I'm running this on CentOS)

     
  17. Is it a remote server? If so, add --bindAddress="0.0.0.0" to your commandline start script and then connect using http://yourserverIP:1080
     
  18. Version 0.3 is now available
    The build error is fixed and Gameseer is now available for download. Please read this entire post even if you have downloaded Gameseer before, a few things have changed since previous versions.

    Notes about version 0.3:
    • Memcached or MySQL is currently required for session storage. Memcached is the preferred option at this time.
    • Due to Gameseer failing to pass unit tests, many of the new features have been stripped out. These features will be rolled out for version 0.4.
    • Gameseer is still not ready for a production environment. Please do not try and run a production server with Gameseer.
    How to install:

    Use an install script:
    Debian: https://www.dropbox.com/s/kl0ytmqjjq1bopu/Debian.sh
    Ubuntu: https://www.dropbox.com/s/kk09dyf4qhc09z3/Ubuntu.sh
    Redhat: https://www.dropbox.com/s/ycrzo1oh8pavpbs/Redhat.sh
    CentOS: https://www.dropbox.com/s/1w2g03ix868olmf/CentOS.sh

    Full steps:
    1. Download and installed NodeJS from nodejs.org/download/. If you are on Linux, you will have to Google for a tutorial as the instructions vary from distro to distro.
    2. Download and installed memcached from

      Alternatively, download and install Couchbase from http://www.couchbase.com/. Couchbase is a NoSQL database server that functions much like memcached but adds many, many new features and performance improvements. It is a drag and drop replacement and nothing should need to be modified in Gameseer for it to work. I have not yet tested Couchbase with Gameseer but plan to do so soon.
    3. Download and unzip Gameseer from http://gameseer.net/latest.
    4. Use your terminal and head to the directory where you unzipped Gameseer.
    5. Run the following command 'npm install'. This command will install all dependencies needed by Gameseer into the Gameseer folder (easy cleanup).
    6. Use terminal to start Gameseer by running the command 'node Main.js' or run one of the included start scripts.
    7. Using the default settings, you can now connect to Gameseer by heading to http://localhost in your browser. If you are running Gameseer from the machine you will be accessing it from, you do not need to read the next few install steps

      Do not perform the following unless you want to play with Gameseer's settings or if Gameseer is running a remote server
    8. Inside your Gameseer folder, edit /util/settings/default.js. Select everything and replace it with the code found at http://pastebin.com/DqCZr56m. My build instructions accidentally minified the settings and I have yet to find a decent workaround. I will figure out something for version 0.4.
    9. Under webserver, change 'bindAddress' from 'localhost' to '0.0.0.0'. You may also change 'httpPort' from 80 to whatever you like.
    10. Run Gameseer using the command in step 6.
    Troubleshooting:
    I have yet to have any issues with Gameseer, probably because I know it like the back of my hand. If you need any help please post here and I will reply as soon as I can.

    Roadmap:
    I will be spending the next 10 days solely on Gameseer. I do not have school during the next 10 days and will be able to put an extra 9 hours in every day. I would like to release version 0.4 as soon as possible, the middle of next week (or earlier, depends on the number of bugs) is looking like a good target.

    Edit: Gameseer version 0.3.1 has been uploaded. Fixes MySQL being the default storage engine and the settings file being minified.
     
    #558 SirSavary, Mar 6, 2014
    Last edited: Mar 6, 2014
    • Like Like x 5
    • Friendly Friendly x 1
  19. Installed and working alright? Any problems or anything? Even a teeny tiny little annoyance?