1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Getting error with HorseKeep plugin

Discussion in 'Bugs & Feature Requests' started by bLanark, Jul 10, 2013.

  1. Hi, I'm thinking of moving my server from bukkit to spigot, and in my testing have found only one issue, with a new plugin which allows players to protect horses (from theft and damage).

    In the server log I see :

    2013-07-10 13:35:19 [SEVERE] [HorseKeep] HorseKeep v0.1 attempted to register an invalid EventHandler method signature "public boolean com.gmail.falistos.HorseKeep.HorseKeep.onCommand(org.bukkit.command.CommandSender,org.bukkit.command.Command,java.lang.String,java.lang.String[])" in class com.gmail.falistos.HorseKeep.HorseKeep

    I am running CraftBukkit version git-Spigot-1022 (MC: 1.6.2) (Implementing API version 1.6.2-R0.1-SNAPSHOT)

    Is the Spigot implementation of the Bukkit API incomplete or is the plugin developer using methods outside the official API? I've asked them too, but if you can have a glance and go "yeah, actually ....." either way that would be great. (I asked here).
     
  2. Hmm, I'm getting this error with a CraftBukkit as well. Sorry to disturb you. I'm gonna lurk some more with a view to using spigot.