Spigot GlowFeller 1.2.0

Shoot down nether glowstone structures for easier gathering

  1. OffLuffy submitted a new resource:

    GlowFeller - Shoot down nether glowstone structures for easier gathering

    Read more about this resource...
     
    • Creative Creative x 1
  2. This is a nice/creative idea. +1.
     
  3. OffLuffy updated GlowFeller with a new update entry:

    1.1.0 for 1.13

    Read the rest of this update entry...
     
  4. Will this work in 1.12 versions, also a suggestion to make it so that when glowstone is shot with a certain type of arrow (spectral) then it will act as a silk touch pick and drop the block itself instead of the powder
     
    • Like Like x 1
  5. It should work on 1.12.2 -- I haven't marked it as compatible since I simply haven't tested it properly, but if I roll back my dependency to 1.12.2, it doesn't show any errors, meaning I'm not referencing anything that changes between 1.12.2 and 1.13. If you give it a try, do let me know how it works.

    I think that's an alright idea. If I can figure out how the arrows work (I've never used them like that), then I'll see if I can't do that. Possibly making the arrow type configurable simply because spectral doesn't make much more sense than probably any other type. It's also possible to check for enchantments on the bow I'd like to think. I'll think about that one, thanks!

    At any rate, I'm due to probably update the plugin anyways as I'm trying to get everything compiled against Java 1.8. Surely no one needs it compiled against 1.6 anymore. *fingers crossed*
     
  6. Ok will let you know how I go when I test it.

    I see, good point about the arrows not making sense making them editable would be cool, another idea is to make it so that bows can use silk touch but that sounds harder to do on your end, whatever is easier I guess.

    Who uses 1.7 anymore lol didn't realize ppl still use it? I've never used 1.7 lol didn't realize that was still a thing heh. Although I guess it would make sense if it were for older versions of minecraft 1.7,1.8, 1.9 etc
     
  7. @OffLuffy
    Found this error

    Code (Text):
    [06:57:52 ERROR]: Error occurred while enabling GlowFeller v1.1.0 (Is it up to date?)
    java.lang.NoSuchFieldError: NETHER_QUARTZ_ORE
            at me.offluffy.GlowFeller.listeners.ArrowHitGlowstoneListener.<init>(ArrowHitGlowstoneListener.java:26) ~[?:?]
            at me.offluffy.GlowFeller.GlowFeller.onEnable(GlowFeller.java:14) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.12.2.jar:git-Paper-1533]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:316) ~[patched_1.12.2.jar:git-Paper-1533]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) ~[patched_1.12.2.jar:git-Paper-1533]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:395) ~[patched_1.12.2.jar:git-Paper-1533]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:344) ~[patched_1.12.2.jar:git-Paper-1533]
            at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:442) ~[patched_1.12.2.jar:git-Paper-1533]
            at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:403) ~[patched_1.12.2.jar:git-Paper-1533]
            at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:341) ~[patched_1.12.2.jar:git-Paper-1533]
            at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:289) ~[patched_1.12.2.jar:git-Paper-1533]
            at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[patched_1.12.2.jar:git-Paper-1533]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
     
    • Useful Useful x 1
  8. I'll get right to fixing that. See where the error is now, thanks!
     
    • Winner Winner x 1
  9. OffLuffy updated GlowFeller with a new update entry:

    v1.2.0

    Read the rest of this update entry...
     
    • Optimistic Optimistic x 1
  10. As you might can tell from the above few posts, this update only took about 7 hours to write and test. That means there is quite possibly some bugs that I didn't find. Let me know if there's something that needs fixing again!
     
    • Agree Agree x 1
  11. Working flawlessly so far great work!

    EDIT - Well in 1.12.2 that is... Still yet to test in 1.13
     
    #12 Alter-Ego, Aug 6, 2018
    Last edited: Aug 6, 2018
    • Useful Useful x 1
  12. It worked in 1.13 but does this plugin now work in 1.13.1?
     
  13. We tested it very briefly - It seemed to work fine. No console spam or such. If ya find a bug, do report it here!
     
  14. Decided to test this plugin on Spigot 1.14 (R0.1-SNAPSHOT) and it appears to be working as intended. Initialized with no errors and so far and after summoning 5 players to stress test it at once it appears to be working with no hitch. For this current spigot version at the very least. Will update if any issues is found.
    Good plugin, very creative and fun idea to prevent those ugly cobble/netherrack pillars.

    Only caveat, if you want to consider it a caveat, that I found is that players can place torches underneath to get the full blocks to drop (unsure if its behavior only on this spigot version so take it with a grain of salt). A minor exploit but to some it might not be desired. A fix for that exploit might be appreciated by more hardcore server owners.
     
    #15 ImNotShady, Apr 30, 2019
    Last edited: Apr 30, 2019
    • Useful Useful x 1