Spigot goBrush 3.7.2-20

Easy way to terraform using heightmaps

  1. Arcaniax

    Supporter

    Arcaniax submitted a new resource:

    goBrush - Easy way to terraform using heightmaps

    Read more about this resource...
     
    • Winner Winner x 1
  2. Interesting, works with Minecraft 1.10.2?
     
  3. Arcaniax

    Supporter

    should work yea
     
    • Like Like x 1
  4. Arcaniax

    Supporter

    Arcaniax updated goBrush with a new update entry:

    2.0 Update

    Read the rest of this update entry...
     
  5. So much awesome ! Are there any brushes pack to download ? :p
    Thanks !
     
  6. Arcaniax

    Supporter

    in the latest version you could easily make some yourself with /gb export [name],
    but you can also get a link to more brushes with /gb info
     
    • Like Like x 1
  7. I installed the latest version of this plugin on my server with the latest version of Plotsquared installed and the GUI for this plugin works, but when I right click the flint nothing happens.
     
    • Agree Agree x 3
  8. This looks like a really cool Plugin, but whenever I start my server with goBrush, i get this error:

    Error occurred while enabling goBrush v2.0 (Is it up to date?)
    java.lang.NullPointerException
    at gc.arcaniax.gobrush.Session.initializeValidBrushes(Session.java:73) ~[?:?]
    at gc.arcaniax.gobrush.Main.onEnable(Main.java:26) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:329) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugin(CraftServer.java:358) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:320) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:404) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:369) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:324) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:243) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:514) [craftbukkit-1.10.2.jar:git-Bukkit-c1b529e]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_102]

    With spigot 1.10.2 and 1.10 i basically get the same error...
     
  9. Arcaniax

    Supporter

    did you put the goBrush folder in your plugins folder too? that contains the heightmaps :)
     
    • Like Like x 1
  10. Thanks for the help, that did it! :)

    But it would be cool, if this plugin would work like FastAsyncWorldEdit (https://www.spigotmc.org/resources/free-fast-async-worldedit-voxelsniper-βeta.13932/) to eliminate lagg, even with bigger brushes.
    And I also would appreciate a feature to export a brush, just like in goPaint.

    For the rest, I really love this plugin! Keep up the good work :)
     
  11. Arcaniax

    Supporter

    In theory I could most likely make the block placing more efficient, but I am not planning to make the blocks packet based because that could break a lot of things
     
  12. Hmm... Okay, thats a bit unfortunate. But thanks anyway, still an awesome Plugin :D
     
  13. Hi, this a really nice plugin. I'm was using it on my old server, and it was working awesome. But now, my friends want to join, and I'm thinking about making the server public. I've set up a plot world, using plotSquared, and the WorldEdit and VoxelSniper restrictors work like a charm (I can only use them in my plot), but I can't use goBrush AT ALL in the plot world. Not on my plot, not on others, not anywhere. I op myself, give myself gobrush.*, but nothing happens. When I go into a normal world, it works like a charm. I really need this for my peeps.

    I guess my main question is if this plugin works with Plot Squared. Is it a configuration issue? I have no idea where to start asking. Thanks in advance for the reply, and I really hope I'm not being stupid...
     
    • Agree Agree x 2
  14. Arcaniax

    Supporter

    Plotsquared's API tends to break when you change versions, if you dm me with the version of Plotsquared I could make you a compatible version :)
     
    • Friendly Friendly x 1
  15. I have this same problem!
    Could you send me one to please?
     
  16. Arcaniax

    Supporter

    DM me your version from plotsquared :)
     
  17. Hi,
    I started a creative network and this plugin is perfect for my server.
    I have some problems with PlotSquared:
    Code (Text):
    [17:04:58 ERROR]: Could not pass event PlayerInteractEvent to goBrush v2.0
    org.bukkit.event.EventException
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:228) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:195) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:191) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:717) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:52) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.PacketPlayInBlockPlace.a(PacketPlayInBlockPlace.java:1) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_65]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_65]
        at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot_server.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_65]
    Caused by: java.lang.NoSuchMethodError: com.intellectualcrafters.plot.object.Plot.getOwners()Ljava/util/HashSet;
        at gc.arcaniax.gobrush.util.PlotSquared.canPlaceBlock(PlotSquared.java:60) ~[?:?]
        at gc.arcaniax.gobrush.listener.PlayerInteractListener.onClickEvent(PlayerInteractListener.java:73) ~[?:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_65]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_65]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_65]
        at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_65]
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24]
        ... 18 more
     
    I use PlotSquared version 3.5.0
    (GoPaint works perfect.)
    - Jens
     
    #17 jensuenk, Dec 6, 2016
    Last edited: Dec 6, 2016
    • Like Like x 1
  18. Hi, this has been working perfectly for a while now on my server. (Everyone loves it) I was wondering if you could update it to 1.11? I'd sincerely appreciate it :)
     
  19. Thank you! I use version 3.5.0u2
     
  20. Would you consider converting/porting a version of this for Sponge and or Forge?