Good TPS but player freeze & lag

Discussion in 'Performance Tweaking' started by Mineria, Jan 13, 2018.

  1. Hi,

    I am running Spigot and BungeeCord on a 32GB ram dedicated server, with SSD.

    I tweaked my Java start-line to get the most out of it and did additionnals tweaks to the spigot/bukkit configuration file. The TPS is really good, and even with about 100 online players, TPS il still more than 19.

    The thing is, people are leaving because they experience lag/freeze on the server. (player stop moving or rollback, chat freeze, ...).

    I tried to check the network part of my server and it seems ok. I also tried disabling a few plugins (even though TPS was good) but without any success.

    I would appreciate if someone can help me solve those issues :)

    Here is a timing report : https://timings.spigotmc.org/?url=lutiqosopu

    Many thanks
     
  2. Most likely something bungeecord or actual internet thats causing this issue
     
  3. I have the same problem as you. Did you fix it?
     
  4. Can you run this command "/wg profile -p 3" this will run a cpu profile then with the sample it gives in the form of a link after 3 minutes we can tell whats going on. :)
     
    #4 Abeoji, Mar 1, 2018
    Last edited: Mar 1, 2018
  5. Here you have mine: http://paste.enginehub.org/HZapac.profile
     
  6. Yes I am running a bungeecord.
    My dedicated server is a SoYouStart Game#2
    I don't know what happens but as I told you when we reach 150 players it starts with lag spikes (whole machine not just the server) every 5 minutes.
    What do you think it could be?
    Faulty SSD?
    If you want to PM me you can
     
  7. Possibly but when it starts to lag I want you to run the same command because
    link it to me and run a timings report as well send both when it is lagging
    so we can best pinpoint this
     
  8. bad internet maybe...
     
  9. Check the ping / latency :D
     

Share This Page