Spigot GParticles 5.2.1

An awesome cosmetics plugin with particles, trails and gadgets ! [1.7-1.15]

  1. Which plugins did you remove?
     
  2. blockdisguise, mineturtle, moremobtypes, piggypilot, creativekilling and magicspells. I did get rid of mctag but i wanted it back so i put it back. error still happened
     
  3. Hmmm... And you have tried shutting down the server, removing the config-folder for pParticles and starting the server again?

    Also. Check the log for errors from other plugins. Sometimes another plugin can error and screw with plugins that should work....
     
  4. yes. i've tried. I still get errors when i use the particles. and there's no other plugin errors that go along with it :/
     
  5. [17:49:09] [Server thread/INFO]: [pParticles] Enabling pParticles v2.8.5
    [17:49:09] [Server thread/WARN]: [pParticles] Default system encoding may have misread config.yml from plugin jar

    removed the folder for the 4th time. it regenerated the folder and i just found this. what is this?
     
  6. This isn't important.
     
  7. then y am i getting errors? if thats not important, then what would be?
     
  8. I'm sorry, but I don't know what's the problem with your server... :c
     
  9. ok so i found out what the problem was....i took out a plugin and it started working again. Which is odd cuz before i started getting errors, it worked fine. so if its possible....add an option where we can turn off a specific setting? like if we dont want people have trails, we can turn it off in the config? And i know what youre gonna say: "use permissions". I am going to.

    I was using a plugin called trailgui and i guess thats what made pparticles go berserk. So in my logic (keep in mind...i know nothing about coding and am taking a wild guess) maybe if we had that option to turn effects/trails/gagdets off it wouldnt conflict? I dont know.
     
    #109 MsDemonicRaven, Sep 25, 2015
    Last edited: Sep 25, 2015
  10. I have a serious problem :
    If i clic to select gadget but have set give-item-menu to false that purchase it again :/
    Really annoying but still a very good plugin :)
    Can you fix this bug and add playerpoint compatibility ?
     
  11. <333
     
  12. The plugin make my lobbyserver very laggy :/
     
  13. Nice plugin, but things need to be fixed:
    • You should check whether the block under your feet is half-block or not, because it makes people fly a few pixels above the ground and player get kicked for flying
    • Carpet trail allows walking in the air, generating endless carpets on your way
    • There is no disco armor gadget, so you should remove the permission on the plugin page
    • Color gun is very laggy, it can even freeze the server for a few seconds
    Adding permissions to prevent opening each menu would be interesting.

    Edit: not only the color gun is laggy, but the whole effect task is overloading the server:
    [​IMG]
     
    #113 MrSheepSheep, Oct 22, 2015
    Last edited: Oct 27, 2015
  14. Nice plugin, really looking forward to letting my players use it.

    I want to be able to disable some of the more intrusive particles/animations, really happy to see there are permission nodes listed for all individual particles but there does not seem to be any listed for animations! Are there permissions for individual animations? If not, could they be added?
     
  15. You can set the configuration to a bigger value, like this :
    Code (Text):
    ticks: 10
     
    #115 GuillaumeVDN, Oct 30, 2015
    Last edited: Nov 3, 2015
    • Like Like x 1
  16. Changing the ticks to a such high value will slow down the particles a lot, making it not nice to see. I prefer not to use the plugin at all. These timings were generated with 5 people connected...
     
    • Agree Agree x 1
  17. Super cool plugin, i have been searching for this one for so long
     
    • Like Like x 1
  18. Hey, everyone ! I said that'll be no more updates, but I'm finally actually working on a big 1.7, 1.8 and 1.9 update. :D
     
  19. Update to 1.9

    When the next update?

    Good Job!