Spigot Gravy 1.4.6

Never lose your items again

  1. Thanks for reporting the bug I'll look into it.
     
  2. on 1.12.2 on multiple versions console is consistently spammed with errors alongside bugs that half the time doesn't give back the items when breaking the head.
     
  3. That my friend sound like you made a new Word without deleting the previous gravy save. If it's that the case I recommend deleting the save file in gravy folder leave only the config.yml
     
  4. I am using spigot 1.14.3 and can't seem to get graves to spawn at all. I have gravy.grave and gravy.info set and the worlds I have tested it on enabled in the config. Is there possibly a plugin conflict?

    Plugins
    Plugins (37): LuckPerms, dynmap, Wild, WorldEdit, AdvancedReplay, PortalGun, HeadsPlus, ChestSort, WorldGuard, ProtocolLib, TARDISChunkGenerator, Realistic_World, mcMMO, ItemNBTAPI, SmoothTimber, Vault, CustomSkinsManager, Essentials, backpacksplus, PlotSquared, LWC, MudgeClicker, Multiverse-Core, Multiverse-Inventories, WolfyUtilities, ProtectionLib, WG-GUI, EssentialsChat, PhatLoots, gravy, Multiverse-Portals, MyPet, CustomCrafting, TARDIS, FurnitureLib, Dynmap-TARDIS, DiceFurniture

    Config
    Code (Text):

    debug_mode: false
    enable_chat_prefix: true
    chat_line_color: '&2'
    save_timer: 60
    grave_timer: 1200
    enable_timer: true
    grave_block: DIRT
    spawn_zombie_on_not_owner_break: true
    spawn_zombie_on_owner_break: false
    zombie_hp: 20
    can_zombie_pickup_items: true
    execute_command_on_respawn: false
    execute_command_on_grave_break: false
    command_: ''
    command_on_grave_break: ''
    drop_items_on_player_kill: false
    enable_token_use: true
    enable_token_craft: true
    enable_token_drop: true
    token_drop_mob: GHAST
    token_drop_amount: 1
    token_drop_chance: 0.05
    token_item: MAGMA_CREAM
    token_craft_recipe: GOLD_INGOT:GOLD_INGOT:GOLD_INGOT-GOLD_INGOT:DIAMOND:GOLD_INGOT-GOLD_INGOT:CHEST:GOLD_INGOT
    use_vault: false
    grave_cost: 500
    enable_worldguard_support: true
    worlds_aliases:
    - Main::The Overworld
    - Main_nether::The Nether
    - Main_the_end::The End
    - Plotland::Plot Land
    disabled_worlds:
    - change_me
     
     
  5. The only thing I can see is "enable_token_use: true" if this is set to true you need to have a token in your inventory for the grave to spawn,
     
  6. Thank you very much. I figured I was missing something easy. Works great now!
     
  7. hey i tryed to get the graves only working but it doesnt seem to get working
     
  8. trying to get this setup but seems like im the only who can craft and get the token drops :/
     
  9. Check this reply as I was having issues as well.
     
  10. you need to setup permissions for the non OP player to be able to use the plugin, check the plugin main page for a list of permissions available.
     
  11. Yhea i DID but its giving me alot of errors on 1.14.3
     
  12. can you post the console log? so I can see what's exactelly the problem
     

  13. it doesnt spit any errors anymore but it doesnt place a grave
     
  14. So the grave only spawn for you? you also need to have items in your inventory, the grave will not span if you have nothing in your inventory
     

  15. i got it Fixed The disable token thing in the config dident work how i thaugth that it worked
     
  16. Spigot 1.14.3 - Gravy Version: 1.4.2 - Bisect Host
    No permissions currently set up, using as op to test out. I like the idea and I can see that it works, but I cannot configure it. I saw a note that in 1.2 (I think) you fixed it to no longer reset the config file but mine is doing exactly that. I tried downloading it and setting it as a 'read-only' file then reuploading, doesn't hold out against the /reload and I can't lock it directly on the web-based file manager from Bisect. Everything else works thought. Really like the craftable portion of it.
    Also, no other plugin is giving me this problem.
     
  17. I didn't had time to fix the config yet, you just need to stop the server make changes then restart it
     
  18. Anyone know what's causing this error on my console? It keeps spitting out this error every second.
    The plugin works fine, but sometimes /gravy recover doesn't work.
    Capture.JPG

    Currently using Spigot 1.14.3 via Shockbyte (Multicraft Control Panel)
     
  19. did you delete anything from your save files, in the gravy folder? The console don't tell me much :(
    dose it happen when you try using a command or dose happen periodically
     
  20. Deleting the gravy data fixed it, later on when someone dies it generates these errors again after a while