GROUP MANAGER PROBLEM

Discussion in 'Spigot Plugin Help' started by ItzKaden, May 29, 2017.

  1. So when i put permissions in this morning and restarted the server I got a error.log file

    2017-05-29 15-58
    =============================== GM ERROR LOG ===============================
    = ERROR REPORT START - Pre2.14.1.3 FINAL (Phoenix) =

    java.lang.IllegalArgumentException: The following file couldn't pass on Parser.
    plugins/GroupManager/worlds/world/groups.yml
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:590)
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:510)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.loadWorld(WorldsHolder.java:678)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.loadWorld(WorldsHolder.java:640)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialWorldLoading(WorldsHolder.java:110)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialLoad(WorldsHolder.java:100)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.resetWorldsHolder(WorldsHolder.java:92)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.<init>(WorldsHolder.java:59)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:179)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:103)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357)
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317)
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414)
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378)
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333)
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263)
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: while parsing a block mapping
    in 'reader', line 12, column 3:
    Helper:
    ^
    expected <block end>, but found BlockSequenceStart
    in 'reader', line 38, column 4:
    - essentials.ban
    ^

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:224)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120)
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:393)
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:585)
    ... 20 more

    ============================================================================

    2017-05-29 16-04
    =============================== GM ERROR LOG ===============================
    = ERROR REPORT START - Pre2.14.1.3 FINAL (Phoenix) =

    java.lang.IllegalArgumentException: The following file couldn't pass on Parser.
    plugins/GroupManager/worlds/world/groups.yml
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:590)
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:510)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.loadWorld(WorldsHolder.java:678)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.loadWorld(WorldsHolder.java:640)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialWorldLoading(WorldsHolder.java:110)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialLoad(WorldsHolder.java:100)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.resetWorldsHolder(WorldsHolder.java:92)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.<init>(WorldsHolder.java:59)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:179)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:103)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357)
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317)
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414)
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378)
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333)
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263)
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: while parsing a block mapping
    in 'reader', line 36, column 5:
    default: false
    ^
    expected <block end>, but found BlockEntry
    in 'reader', line 38, column 5:
    - essentials.ban
    ^

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570)
    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:224)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229)
    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120)
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450)
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:393)
    at org.anjocaido.groupmanager.dataholder.WorldDataHolder.loadGroups(WorldDataHolder.java:585)
    ... 20 more

    ============================================================================
     
  2. Caused by: while parsing a block mapping
    in 'reader', line 12, column 3:
    Helper:
    ^

    There is an error with your spacing
     
  3. what about essentials.ban
     
  4. It's a YML error in your file. Also I HIGHLY suggest moving to PermissionsEX.
     
    • Agree Agree x 1
  5. Okay how do you move the permission files
     
  6. Use LuckyPerms. GroupManager is outdated
     
  7. Use permissions ex its much better. And please use pastebin when sending errors. https://dev.bukkit.org/projects/permissionsex
     
  8. Use PEX as stated above. GroupManager is for beginners. Join the "big kid's club" and use PEX.
     
  9. I use a EssentialsX version of Groupmanager and it still works with no problem. Just give me the Groupmanager folder and I will see for you if I can help you.
     
  10. Can you post the file groups.yml? I need it in order to fix it, there are multiple errors. If you send me a pastebin link, I'll return a working file.
     
  11. I have no problem with groupManager, and as not-big-boy-club member I have been able to get it to work. No need to use PEX (just yet).
    :p
    Looking at pex and gm, their config files aren't that much different, .. to be honest. The same "skillset" to manage permissions seems to be required.

    I'd love to learn, explain to me why i should upgrade my 1.12-pre6 groupmanager to pex? Maybe you can convince me and invite me to the big boy club as this might be a good time to consider updating. Is there a jenkins build page for permissionEX plugin and a spigot page, or do i have to use the equally outdated and unmaintained release- which doesn't seem to be any better than GM right now..

    Looking forward hearing from you. Maybe i can finally find a real easy to convert to and manage and adaptable permissions manager for spigot 1.12 that is actively maintained and has a reputation of being good.
     
  12. Gaxan

    Supporter

    If you are referring to GroupManagerX, it has nothing to do with EssentialsX. Two different development teams.
     
    • Informative Informative x 1
  13. Gaxan

    Supporter

    No thanks, I would take LuckPerms over PeX any day.
     
  14. @ItzKaden Paste your config file at pastbin.com
     
  15. can you give us a update? you fix it or?